We use cookies to give you the best experience on our website. If you continue to browse, then you agree to our privacy policy and cookie policy. (Last updated on: June 24, 2019).
Unfortunately, activation email could not send to your email. Please try again.
Syncfusion Feedback

Update 17.3.0.17 ForeignKey not record load (CRUD SQLSERVER)

Thread ID:

Created:

Updated:

Platform:

Replies:

148290 Oct 14,2019 07:59 AM UTC Oct 17,2019 10:58 AM UTC Blazor 3
loading
Tags: Grid
Piet Cris
Asked On October 14, 2019 07:59 AM UTC

Update 17.3.0.17 - ForeignKey not record load (CRUD SQLSERVER)
load load ...

17.3.0.11 its ok

Vignesh Natarajan [Syncfusion]
Replied On October 15, 2019 01:55 PM UTC

Hi Piet,  

Thanks for contacting Syncfusion forums. 

Query: “Update 17.3.0.17 - ForeignKey not record load (CRUD SQLSERVER) 
 
To validate the reported issue at our end, we have prepared a Client side Blazor application and bound the Grid and Column dataSource asynchronously from WebAPI service. We are not able to reproduce the reported issue at our end. Kindly download the sample from below 


After referring the sample, kindly share the following details.  

  1. Share the Grid rendering code example.
  2. Are you facing any script error in console window. (if yes, share the screenshot along with stack trace of the issue).
  3. Share your application type (client side or hosted).
  4. Share the details how you have bunded the column dataSource with sql server.

Requested details will be helpful for us to validate the reported issue at our end and provide the solution as soon as possible.       

Regards, 
Vignesh Natarajan.

Piet Cris
Replied On October 16, 2019 12:06 PM UTC

Thank you very much. I attached my project

Attachment: BibRoWeb_3d607c6b.zip

Vignesh Natarajan [Syncfusion]
Replied On October 17, 2019 10:58 AM UTC

Hi Piet,  

Thanks for sharing your project. 

We have analyzed your project. While running your project, it has requested us to Applying Migrations to connect your database. We have applied that migrations in that project and ran the sample. Grid is rendered with empty dataSource. From your database itself, no records were returned. For your convenience we have prepared a video demonstration of the sample.  


Kindly share the video demonstration of the issue you are facing with the latest source.  

Regards, 
Vignesh Natarajan. 


CONFIRMATION

This post will be permanently deleted. Are you sure you want to continue?

Sorry, An error occured while processing your request. Please try again later.

Please sign in to access our forum

This page will automatically be redirected to the sign-in page in 10 seconds.

Warning Icon You are using an outdated version of Internet Explorer that may not display all features of this and other websites. Upgrade to Internet Explorer 8 or newer for a better experience.Close Icon

Live Chat Icon For mobile
Live Chat Icon