We use cookies to give you the best experience on our website. If you continue to browse, then you agree to our privacy policy and cookie policy. (Last updated on: June 24, 2019).
Unfortunately, activation email could not send to your email. Please try again.
Syncfusion Feedback

Date column not working

Thread ID:

Created:

Updated:

Platform:

Replies:

148065 Oct 3,2019 08:01 PM UTC Oct 8,2019 06:41 AM UTC Blazor 5
loading
Tags: Grid
Ivan Petrov
Asked On October 3, 2019 08:01 PM UTC

Hello,
When I updated to the newest version a column of type date stopped showing the data. It was working correctly before.

Renjith Singh Rajendran [Syncfusion]
Replied On October 4, 2019 11:17 AM UTC

Hi Ivan, 

Thanks for contacting Syncfusion support. 

We have tried to reproduce the reported problem from our side by creating a sample with our latest version 17.3.11 by having a date column in Grid. But we could not reproduce the reported problem. Grid shows the date column values. We are attaching the sample for your convenience, please download the sample from the link below, 
 
 
<GridColumn Field=@nameof(Order.OrderDate) HeaderText="Order Date" Format="yMd" Type="ColumnType.Date" Width="150"></GridColumn> 
 
 
If you are still facing the reported problem, we need more details to further proceed on this. Kindly share with us the following details for better assistance. 
  1. Share the Syncfusion Blazor version details.
  2. Share the sample which you have tried from your side.
  3. Share the exact scenario or proper replication procedure.

The provided information will help us analyze the problem, and provide you a solution as early as possible. 

Regards, 
Renjith Singh Rajendran. 


Ivan Petrov
Replied On October 6, 2019 11:47 PM UTC

I think the problem occurs when the date is saved in the database like 2019-10-06 00:52:35.7125962. When it is set as 2019-10-06 00:00:00.0000000 (only the date is set) it works correctly. So if I save it using DataTime.UtcNow it won't work. It also doesn't work if I choose ColumnType.DateTime.

Vignesh Natarajan [Syncfusion]
Replied On October 7, 2019 10:29 AM UTC

Hi Ivan,  

Query: “I think the problem occurs when the date is saved in the database like 2019-10-06 00:52:35.7125962 

As per your suggestion we have prepared a sample with DateTime column and we are able to update the values properly while editing. We have also ensured the reported issue by preparing a sample with DateTime.UtcNow and editing. We are not able to reproduce the reported issue at our end. Kindly download the sample from below link which we have prepared using latest version Nuget version and Scripts files. 


Kindly share the following details which will be helpful for us to validate the reported issue at our end.   

  1. Are you facing the issue during initial rendering or during the Edit action?
  2. Share the details about the Grid dataSource. If you are using any type of adaptor, share the details.
  3. Share the video demonstration along with replication procedure.
  4. If possible share the issue reproducible sample or try to reproduce the reported issue in provided sample.
  5. Also ensure that you have referred latest version script and css files.
<link rel='nofollow' href="https://cdn.syncfusion.com/ej2/17.3.11/material.css" rel="stylesheet" /> 
 
  
Regards, 
Vignesh Natarajan. 


Michael Diez
Replied On October 7, 2019 02:23 PM UTC

Same Problem here.

Grid stopped working with dates like "2019-03-28T12:11:51.327"

It will display "Invalid Date " or blank cell.

If a row  is Selected following Error is thrown:
 ejs.interop.min.js:1 Failed to execute 'add' on 'DOMTokenList': The token provided must not be empty.
Error: Failed to execute 'add' on 'DOMTokenList': The token provided must not be empty.
    at S (https://cdn.syncfusion.com/ej2/17.3.11/dist/ej2.min.js:1:3641)
    at t.initialize (https://cdn.syncfusion.com/ej2/17.3.11/dist/ej2.min.js:1:637503)
    at t.render (https://cdn.syncfusion.com/ej2/17.3.11/dist/ej2.min.js:1:637418)
    at t.appendTo (https://cdn.syncfusion.com/ej2/17.3.11/dist/ej2.min.js:1:470276)
    at Object.invokeEJS (https://localhost:44305/_content/Syncfusion.EJ2.Blazor/ejs.interop.min.js:1:3041)
    at https://localhost:44305/_framework/blazor.webassembly.js:1:6925
    at new Promise (<anonymous>)
    at Object.beginInvokeJSFromDotNet (https://localhost:44305/_framework/blazor.webassembly.js:1:6894)
    at _mono_wasm_invoke_js_marshalled (https://localhost:44305/_framework/wasm/mono.js:1:176019)
    at wasm-function[6322]:370

Best Regards 
Michael Diez

Vignesh Natarajan [Syncfusion]
Replied On October 8, 2019 06:41 AM UTC

Hi Ivan & Michael,  

Sorry for the inconvenience  

Query1: “ I think the problem occurs when the date is saved in the database like 2019-10-06 00:52:35.7125962 &&Grid stopped working with dates like "2019-03-28T12:11:51.327" 

We have validated the reported issue at our end and we are able to reproduce the reported issue at our end too. We have confirmed it is breaking issue and logged defect report “DateTime object are not properly serialized while binding it to Grid” for the same. We will fix the issue and it will be included in our upcoming Nuget release which is expected to be rolled out on or before 16th October 2019.  
You can now track the current status of your request, review the proposed resolution timeline, and contact us for any further inquiries through this link. 
 

We appreciate your patience until then.  

Regards, 
Vignesh Natarajan. 


CONFIRMATION

This post will be permanently deleted. Are you sure you want to continue?

Sorry, An error occured while processing your request. Please try again later.

Please sign in to access our forum

This page will automatically be redirected to the sign-in page in 10 seconds.

Warning Icon You are using an outdated version of Internet Explorer that may not display all features of this and other websites. Upgrade to Internet Explorer 8 or newer for a better experience.Close Icon

Live Chat Icon For mobile
Live Chat Icon