We use cookies to give you the best experience on our website. If you continue to browse, then you agree to our privacy policy and cookie policy. (Last updated on: June 24, 2019).
Unfortunately, activation email could not send to your email. Please try again.
Syncfusion Feedback

Grid does not display the date filter

Thread ID:

Created:

Updated:

Platform:

Replies:

148015 Oct 2,2019 12:01 AM UTC Oct 3,2019 09:23 AM UTC Vue 3
loading
Tags: Data Grid
Jonatan Tlilayatzi Cruz
Asked On October 2, 2019 12:01 AM UTC

Hello, when I have a column of type date and with excel filter it shows me the filter to select the options: greater than etc, and I can visualize the calendar to select a date, but when I change the configuration to another language, it allows me to select the date but it doesn't show me the calendar and I get the following error:
What could it be?

Manivel Sellamuthu [Syncfusion]
Replied On October 2, 2019 10:03 AM UTC

Hi Jonatan, 

Thanks for contacting us. 

We suspect that the locale files are not referred to your project is the cause of the issue. Please find the below documentation link for more information. 


If you still faced the issue please get back to us with the Grid code 

Regards, 
Manivel 


Jonatan Tlilayatzi Cruz
Replied On October 2, 2019 05:57 PM UTC

Thanks for the answer, to be more precise in my Grid when I put the culture to es-MX everything works fine except for the date type column that when I want to sort the dates I don't get the calendar.
It stays like this and does not show the following window
Expected     *It doesn't show when I change it to es-MX

I have the filter Settings enabled for Excel and I have the following configuration in my component
And I have my translation in another separate file .ts
This is my grid
Thanks in advance for the attention given

Seeni Sakthi Kumar Seeni Raj [Syncfusion]
Replied On October 3, 2019 09:23 AM UTC

Hi Jonatan, 

Thanks for your update and sharing the details. 

We could see that you have applied es-MX (spanish) cuture using setCulture method but referred the locale files for ‘de’ (German) which is the cause of the issue. So we suggest you to refer the locale files for es-MX culture to resolve the issue. 

Please find the below screenshot and sample for more information 

Screenshot: 

 

 


Please get back to us, if you need further assistance. 

Regards, 
Seeni Sakthi Kumar S 


CONFIRMATION

This post will be permanently deleted. Are you sure you want to continue?

Sorry, An error occured while processing your request. Please try again later.

Please sign in to access our forum

This page will automatically be redirected to the sign-in page in 10 seconds.

Warning Icon You are using an outdated version of Internet Explorer that may not display all features of this and other websites. Upgrade to Internet Explorer 8 or newer for a better experience.Close Icon

Live Chat Icon For mobile
Live Chat Icon