We use cookies to give you the best experience on our website. If you continue to browse, then you agree to our privacy policy and cookie policy. Image for the cookie policy date
close icon

Presentation (Power Point) cloning a slide throws an error

Hey,

so I have a slide with a table which I want to clone.
Using this code:

ISlide cloned = presentation.Slides[4].Clone();

I always get the following error:

at Syncfusion.Presentation.TableImplementation.Cells.SetParent(Table newParent)
   at Syncfusion.Presentation.TableImplementation.Columns.SetParent(Table table)
   at Syncfusion.Presentation.TableImplementation.Table.Clone()
   at Syncfusion.Presentation.Drawing.Shapes.CloneList()
   at Syncfusion.Presentation.Drawing.Shapes.Clone()
   at Syncfusion.Presentation.SlideImplementation.BaseSlide.Clone(BaseSlide newParent)
   at Syncfusion.Presentation.SlideImplementation.Slide.Clone()

Is there a way to fix this on my side?

3 Replies

VA Vijayasurya Anandhan Syncfusion Team August 30, 2019 08:55 AM UTC

Hi Paul,

Thank you for contacting Syncfusion support.

We have tried to reproduce the issue, but it works fine in our end. Please find the sample used in our end to reproduce the issue from the below link: 
https://www.syncfusion.com/downloads/support/forum/147032/ze/Table1532398421.zip

We suspect that the problem might be due to the contents in the input PowerPoint presentation which used at your end. So, could you please provide us the below details to reproduce the problem in our end.

1. Input PowerPoint presentation.
2. Modified sample with complete code example.
3. Product version

Thereby we will analyze further and provide you the appropriate solution at the earliest.

Note: If you have any confidential data in your PowerPoint presentation, please replace with some dummy data and provide us the same. We just need your document to recreate the problem you face.

Regards,
Vijayasurya A
 



PA Paul Abramov September 2, 2019 01:03 PM UTC

Thank you for your fast answer!

I've found the issue. So i was working with the documentation here:

https://help.syncfusion.com/file-formats/presentation/working-with-powerpoint-presentation

So as it described, I cloned the presentation to prevent changes on the source file. While doing this I could not clone any slide with a table. I've also tested this with the template you have sent me, it threw the same error.
I removed the part where I cloned the source file and just worked with the source file. Now I am able to clone all slides as it should be.

Just letting you know this. Thank you very much for the fast answer and the awesome support! Love your way to attach files, so I am able to check my files/project against yours, helps a lot and fast!


VA Vijayasurya Anandhan Syncfusion Team September 3, 2019 07:10 AM UTC

Hi Paul,

Thank you for your feedback and we are happy to know that your issue is resolved.

Please let us know if you have any questions.

Regards,
Vijayasurya A


Loader.
Live Chat Icon For mobile
Up arrow icon