We use cookies to give you the best experience on our website. If you continue to browse, then you agree to our privacy policy and cookie policy. Image for the cookie policy date
close icon

Input mode not changed

Input mode does not switch even when using InputMethod in SfDataGrid

MappingName="Name" />

6 Replies

SS Susmitha Sundar Syncfusion Team July 15, 2019 01:12 PM UTC

Hi Yama, 
Thank you for contacting Syncfusion support. 
Currently, we are analyzing your reported query “Input method not works on GridTextColumn”. We will validate and update you the details on July 17, 2019. We appreciate your patience until then. 
Susmitha S 

SS Susmitha Sundar Syncfusion Team July 17, 2019 04:09 PM UTC

Hi Yama, 
Thank you for your patience. 
We have checked reported case with WPF DataGrid, but OnScreen key board will not be displayed when the textbox in a cell got focus. We can replicate the same scenario in Microsoft TextBox also. We need the following details for better understanding, 
·        Are you expecting to display the On-Screen keyboard when textbox got focus on touch? 
·        We checked this properties InputMethod.PreferredImeConversionMode="FullShape,Native" InputMethod.PreferredImeState="On" with the framework TextBox. It’s not working as expected. Can you please guide us how you are verifying the IME options against WPF controls? 
If you provide the above details, it will be helpful for us to provide the solution as early as possible. 
Susmitha S 

YA Yama July 18, 2019 04:44 AM UTC

Dear Sir,

Thank you for your response.

What I want to do is not inputting by OnScreen but inputting by the method specific to Asia including Japan.
Like attached screen
The input method changes according to the value of InputMethod.PreferredImeConversionMode.
I want to do the same process in the cell of SfDataGrid control.

Here is a sample with sfTextbox:

        <StackPanel VerticalAlignment="Center">
                Text="normal textbox" />
                Text="カタカナTextbox" />

Attachment: imeSample_f0247120.zip

FP Farjana Parveen Ayubb Syncfusion Team July 24, 2019 10:36 AM UTC

Hi Yama, 
Thank you for your patience. 
We have tried your provided code snippet with SfTextBoxExt, but we could not get that Popup for Japanese language like your provided sample image. Can you please point out us how the suggestion popup is showing at your end? Is there any additional settings that we need to show the suggestion popup when typing?. Moreover, we have workaround for your query. You can use the SfTextBoxExt in GridTemplateColumn. Please refer the following code snippet, 
<syncfusion:GridTemplateColumn MappingName="City"> 
                            <TextBlock Text="{BindingCity}" /> 
                            <syncfusion:SfTextBoxExtText="{Binding City, Mode=TwoWay}" InputMethod.PreferredImeConversionMode="Katakana" 
                                <!--You can do your costomization for SfTextBoxExt--> 
We hope it helps. Please contact us for further assistance. 
Farjana Parveen A 

YA Yama August 19, 2019 09:35 AM UTC

Dear Sir,

Thank you for your response.

I solved it by the method I was taught.


FP Farjana Parveen Ayubb Syncfusion Team August 20, 2019 06:28 AM UTC

Hi Teru, 
Thanks for the update. 
We are glad to know that the reported problem has been resolved at your end. Please let us know if you have any further queries on this. We are happy to help you. 
Farjana Parveen A  

Live Chat Icon For mobile
Up arrow icon