We use cookies to give you the best experience on our website. If you continue to browse, then you agree to our privacy policy and cookie policy. (Last updated on: June 24, 2019).
Unfortunately, activation email could not send to your email. Please try again.
Syncfusion Feedback

Disabling Context Menu

Thread ID:

Created:

Updated:

Platform:

Replies:

145223 Jun 12,2019 11:44 PM UTC Jun 17,2019 10:51 AM UTC WPF 3
loading
Tags: SfSchedule
Shawn Liang
Asked On June 12, 2019 11:44 PM UTC

I was wondering how you'd disable right click context menu completely in SFSchedule?

Looking around the forum it seems I'm able to disable it by getting the ContextMenuOpening event and cancel it but the context menu still pops out when I right click on any appointment. 
I'm able to get it to not appear when I click on non-appointment part of the control but it doesn't work once I right click on any sort of appointments.

Any help is appreciated.

Thank you

Jagadeesan Pichaimuthu [Syncfusion]
Replied On June 13, 2019 11:53 AM UTC

Hi Shawn 
 
Thanks for contacting Syncfusion support.   
 
We have tried to reproduce the reported issue “Context menu is not disabled properly” at our end. But we unable to reproduce the reported issue at our end. May be our issue reproducing scenario may differ from yours. So please provide replication steps or your application layout with code snippet or modify the application which we provided below to test it from our side, that would help us to resolve your issue as earlier. Please find the video and sample for the same. 
   
  
   
Regards, 
Jagadeesan 


Shawn Liang
Replied On June 14, 2019 03:58 PM UTC

Hm, I do the exact shame thing as the example but the context menu still pops up for me. I'll go play around with it, maybe it was some setting i did on the SFSchedule that broke it.

Jagadeesan Pichaimuthu [Syncfusion]
Replied On June 17, 2019 10:51 AM UTC

Hi Shawn,  
 
Thanks for you update. 
 
As stated earlier, we are unable to reproduce the reported issue “Context menu is not disabled properly” at our end. Could 
please share the information about your settings of SfSchedule, if possible please share issue reproducible application, that would help us to resolve your issue as earlier. 
 
Regards, 
Jagadeesan 


CONFIRMATION

This post will be permanently deleted. Are you sure you want to continue?

Sorry, An error occured while processing your request. Please try again later.

Please sign in to access our forum

This page will automatically be redirected to the sign-in page in 10 seconds.

Warning Icon You are using an outdated version of Internet Explorer that may not display all features of this and other websites. Upgrade to Internet Explorer 8 or newer for a better experience.Close Icon

Live Chat Icon For mobile
Live Chat Icon