We use cookies to give you the best experience on our website. If you continue to browse, then you agree to our privacy policy and cookie policy. (Last updated on: June 24, 2019).
Unfortunately, activation email could not send to your email. Please try again.
Syncfusion Feedback

No display control

Thread ID:

Created:

Updated:

Platform:

Replies:

145165 Jun 11,2019 12:25 AM UTC Jun 13,2019 05:48 AM UTC Angular - EJ 2 6
loading
Tags: Grid
LUCIANO ALMEIDA PIMENTA
Asked On June 11, 2019 12:25 AM UTC

I can not display a grid in an Angular project 7. 
I created a new project, adapted a template that I have, but it does not display any Syncfusion controls in this project.

I reviewed the settings based on this example: https://www.syncfusion.com/kb/9685/how-to-get-started-easily-with-syncfusion-angular-7-data-grid

My project is the same in the sense of settings, but Grid or DropDownList are not shown. 
I have done the same as the documentation examples, without success.

My project settings:

Angular CLI: 7.3.9
Node: 10.15.3
OS: win32 x64
Angular: 7.2.15
... animations, common, compiler, compiler-cli, core, forms
... language-service, platform-browser, platform-browser-dynamic
router

Package Version
-------------------------------------------------- ---------
@ angular-devkit / architect 0.13.9
@ angular-devkit / build-angular 0.13.9
@ angular-devkit / build-optimizer 0.13.9
@ angular-devkit / build-webpack 0.13.9
@ angular-devkit / core 7.3.9
@ angular-devkit / schematics 7.3.9
angular / cli 7.3.9
@ ngtools / webpack 7.3.9
@ schematics / angular 7.3.9
@ schematics / update 0.13.9
rxjs 6.3.3
typescript 3.2.4
webpack 4.29.0

Pavithra Subramaniyam [Syncfusion]
Replied On June 11, 2019 05:40 AM UTC

Hi Luciano, 

Greetings from Syncfusion. 

From your query and package details we suspect that you have not installed Syncfusion packages in your project. If yes please include the Grid packages in your node_modules to display the Syncfusion components in the given kb. Please find the below documentation link for your reference. 


Please get back to us if you need further assistance. 
 
Regards, 
Pavithra S. 


LUCIANO ALMEIDA PIMENTA
Replied On June 11, 2019 11:21 AM UTC

The packages are installed (picture in attach).

Still not working.

Attachment: packages_6b45c75d.zip

LUCIANO ALMEIDA PIMENTA
Replied On June 11, 2019 11:44 AM UTC

In attach, sample project.

I'm used file datasource.ts in empresa-list.component.ts (Empresa menu).

Attachment: sigaupdate_91bd413a.zip

Pavithra Subramaniyam [Syncfusion]
Replied On June 12, 2019 04:38 AM UTC

Hi LUCIANO, 
 
Thanks for sharing the details with us. 
 
We have validated the sample and found that you have missed to import the “GridModule” inside the ngModule section of “empresa.module.ts” file which is the cause of the reported behavior. So we suggest to import the GridModule to render the Grid inside the empresa routing. Please refer to the below code example for your reference. 
 
[empresa.module.ts] 
import { GridModule } from '@syncfusion/ej2-angular-grids'; 
.  .  . 
 
@NgModule({ 
  imports: [ 
  RouterModule.forChild([ 
    {path: '', component: EmpresaListComponent, canActivateChild: [AuthGuard]}, 
    {path: 'add', component: EmpresaComponent, canActivateChild: [AuthGuard]}, 
    {path: 'edit/:id', component: EmpresaComponent, canActivateChild: [AuthGuard]} 
  ]),  
  CommonModule,GridModule], 
  .   .   . 
}) 
export class EmpresaModule { } 
 
Regards, 
Pavithra S. 


LUCIANO ALMEIDA PIMENTA
Replied On June 12, 2019 10:47 AM UTC

Thank you so much.

It's work.

Pavithra Subramaniyam [Syncfusion]
Replied On June 13, 2019 05:48 AM UTC

Hi LUCIANO, 
 
Thanks for your update. 
 
We are happy to hear that the reported problem has been solved. 
 
Please get back o us if you need any further assistance on this. 
 
Regards, 
Pavithra S. 


CONFIRMATION

This post will be permanently deleted. Are you sure you want to continue?

Sorry, An error occured while processing your request. Please try again later.

Please sign in to access our forum

This page will automatically be redirected to the sign-in page in 10 seconds.

Warning Icon You are using an outdated version of Internet Explorer that may not display all features of this and other websites. Upgrade to Internet Explorer 8 or newer for a better experience.Close Icon

Live Chat Icon For mobile
Live Chat Icon