We use cookies to give you the best experience on our website. If you continue to browse, then you agree to our privacy policy and cookie policy. (Last updated on: June 24, 2019).
Unfortunately, activation email could not send to your email. Please try again.
Syncfusion Feedback

Report rendering

Thread ID:

Created:

Updated:

Platform:

Replies:

144558 May 12,2019 08:42 AM UTC Jun 4,2019 02:38 PM UTC Report Platform 4
loading
Tags: Report Viewer
Vedran Vukasovic
Asked On May 12, 2019 08:42 AM UTC

Hello, 

I would like for a assistance regarding generating and designing local reports (no reporting server).

I installed version 17.1.0.38 Essentail JS 1 package, copied css to www/css, scripts to www/ folder, made API controller,.. 

For a test I used one of Syncfusion reports ("Company Sales", tried .rdl and .rdlc).

I put relevant files in zip file.

Report is rendered but does not show anything.

Ultimate goal is to pick up controller route parameter and get "custom" data filtered by parameter. ("Parameters.jpg").

Could you make example of report with my model (with few fields) that I could use as you showed in your examples? Model "ObracunReportModel.cs"

Could you tell me what I am doing wrong?

Thank you in advanced,
Vedran


Attachment: RelevantFiles_2173737b.zip

Ramesh Thangaraj [Syncfusion]
Replied On May 13, 2019 02:22 PM UTC

Hi Vedran, 
 
Thanks for your interest in our Syncfusion Components.  
 
We are preparing the standalone sample for your requirement and we will update you the sample on 14th May 2019.   
   
Regards,  
Ramesh T.  


Mahendran Shanmugam [Syncfusion]
Replied On May 14, 2019 04:23 PM UTC

Hi Vedran, 

We cannot able to reproduce the mentioned issue. So could you please confirm whether the sample is working or not with your report. 

If issue still persists then could you please revert the sample with issue reproducible case to validate the mentioned problem at our end. 

Regards, 
Mahendran S. 


Vedran Vukasovic
Replied On June 4, 2019 02:17 PM UTC

Hi,

first sorry for not replying so long. I was sick for some time.

I can confirm that your example is working. 

It helped me with my problem. 

And problem was in that I was using different/wrong/newer version of ej.web.all.min.js file (version 17.1.0.38).

After I included 16.3.0.29 version everthing worked. 

Thank you for your help and best regards

Vinoth Srinivasan [Syncfusion]
Replied On June 4, 2019 02:38 PM UTC

Hi Vedran, 

Thanks for your update. Please let us know if you require any further assistance on this. 

Regards, 
Vinoth S. 


CONFIRMATION

This post will be permanently deleted. Are you sure you want to continue?

Sorry, An error occured while processing your request. Please try again later.

Please sign in to access our forum

This page will automatically be redirected to the sign-in page in 10 seconds.

Warning Icon You are using an outdated version of Internet Explorer that may not display all features of this and other websites. Upgrade to Internet Explorer 8 or newer for a better experience.Close Icon

Live Chat Icon For mobile
Live Chat Icon