We use cookies to give you the best experience on our website. If you continue to browse, then you agree to our privacy policy and cookie policy. Image for the cookie policy date

Second Grid in Tab control does not render properly

Hello,
I have a tab control with 3 grids. all 3 grids are Hierarchy grids (master/detail). I have noticed that the default grid that is rendered when tab control first appears is always ok no matter which tab opens first, but the subsequent grids in other tabs do not show the expand button to expand the grid details. I have tried this with both syncfusion tab control and third party tab control with exactly the same results. Please note this issue did not exist in Ej1, please find attached pictures of the 2 scenarios i have depicted.

Attachment: orders_f63041f2.7z

3 Replies

TS Thavasianand Sankaranarayanan Syncfusion Team March 29, 2019 05:11 AM

  
Hi Yoab, 

Greetings from the Syncfusion. 

We have validated your query provided information. we have unable to reproduce the reported problem with current version and we are prepared a sample based on your query. Please sample for more information. 


Could you please provide the below details that will be helpful for us to provide a better solution as early as possible.  

  1. Share video to demonstrate the issue or reproduce the reported problem in our sample.
  2. Share the code sample
 
Please get back to us, if you need further assistance. 
 
Regards, 
Balaji S 



YY Yoab Youssoufou March 29, 2019 05:58 AM

Thanks for your reply. I've gone through the sample, apparently it was as simple as adding textAlign="Right" to the Id Column. I did that on my project and all is working fine now.

Thank you


PS Pavithra Subramaniyam Syncfusion Team March 31, 2019 09:02 PM

Hi Yoab,  

Thanks for your update. 

We are happy to hear that you have resolved the issue. 

Please contact us if you need any further assistance. As always, we will be happy to assist you.  

Regards,  
Pavithra S. 


Loader.
Live Chat Icon For mobile
Up arrow icon