We use cookies to give you the best experience on our website. If you continue to browse, then you agree to our privacy policy and cookie policy. (Last updated on: November 16, 2018).
Unfortunately, activation email could not send to your email. Please try again.
Syncfusion Feedback

Grunt build is not working after NPM Update and Clean

Thread ID:

Created:

Updated:

Platform:

Replies:

143546 Mar 26,2019 11:49 AM UTC Apr 1,2019 11:00 AM UTC AngularJS 3
loading
Tags: General
Rajesh Chauhan
Asked On March 26, 2019 11:49 AM UTC

I have my website on AngularJs and it was working just fine before we updated the NPM clean. Whenever we tried to build the project with 'Grunt Build' it gets stuck after processing the images part.
  • Reinstalled NPM previous version
  • Resetup complete environment
  • Deleted cache and everything

Process Log



Christopher Issac Sunder K [Syncfusion]
Replied On March 27, 2019 11:44 AM UTC

Hi Rajesh, 

We checked your reported issue and we suspect the root cause of it might be that all the dependent packages required for your installed version of nodejs are not properly updated. This causes compatibility issues. It might have worked previously as the packages will be fetched from cache and on clearing the cache all the old packages are reset to the new ones. 

This issue can be resolved by updating all the dependent packages of nodejs to the version that is supported by the installed node version. Otherwise, you can try to downgrade your node version to the older one to resolve this. 

Thanks,
Christo 


Rajesh Chauhan
Replied On March 29, 2019 04:54 PM UTC

I tried updating every package but no luck, I do not have backup of the previous installation, I followed over 35 methods but one of them worked for me :(

Christopher Issac Sunder K [Syncfusion]
Replied On April 1, 2019 11:00 AM UTC

Hi Rajesh, 

We suggest you to try out the following steps, 
  • Have you tried our other suggestion on downgrading the node and packages to the older version used?
  • Can you please check if you have installed all the packages required for the application as “npm clean“ would have cleared all the installed modules and some might not be referenced in the package.json of the application.
  • Can you check if the grunt package installed is supported by the installed node version?

If the issue is still not resolved, could you please share us your application so that we can check it directly and help you resolve it. 

Thanks,
Christo 


CONFIRMATION

This post will be permanently deleted. Are you sure you want to continue?

Sorry, An error occured while processing your request. Please try again later.

Please sign in to access our forum

This page will automatically be redirected to the sign-in page in 10 seconds.

Warning Icon You are using an outdated version of Internet Explorer that may not display all features of this and other websites. Upgrade to Internet Explorer 8 or newer for a better experience.Close Icon

;