We use cookies to give you the best experience on our website. If you continue to browse, then you agree to our privacy policy and cookie policy. (Last updated on: November 16, 2018).
Unfortunately, activation email could not send to your email. Please try again.
Syncfusion Feedback

Masked dots replaced with commas

Thread ID:

Created:

Updated:

Platform:

Replies:

143350 Mar 15,2019 08:40 AM UTC Apr 3,2019 12:09 PM UTC Xamarin.Forms 4
loading
Tags: SfMaskedEdit
Eugen Dolgi
Asked On March 15, 2019 08:40 AM UTC

Dots in the mask are replaced with commas:






Vanaja  Annasamy [Syncfusion]
Replied On March 18, 2019 12:41 PM UTC

Hi Eugen Dolgi,

We have checked the reported behaviour in SfMaskedEdit Control. While checking the reported behaviour, we suspect it may be due to the culture change in the device. If dots are need to be shown as default, please set the default culture as "en-US". We have prepared a simple sample and checked the mentioned behaviour. Please have the sample from the below link.

Sample Link: 
 http://www.syncfusion.com/downloads/support/directtrac/general/ze/MaskedEdit2006393333

Please
check with the sample and let us know if you have any concern.

Regards,
Vanaja R.A


 


Eugen Dolgi
Replied On March 20, 2019 07:22 AM UTC

Suggested solution worked. But it is questionable why delimiters in neither numerical nor temporal mask are culture-sensitive.

And another big nitpick: the text color is not set:



=> 



Mugundhan Saravanan [Syncfusion]
Replied On March 21, 2019 01:05 PM UTC

Hi Eugen Dolgi,

Thanks for your update.

We are able to reproduce the issue from our side. We have already logged a bug report for this issue and we will fix this and we will provide patch  for the reported issue  on March 29,2019.

Please check the following link to track the bug report for the corresponding issue.

Feedback Link: https://www.syncfusion.com/feedback/5323/   

Please let us know if you have any other concern.

Regards,
Mugundhan S.

Bharathiraja K [Syncfusion]
Replied On April 3, 2019 12:09 PM UTC

Hi Eugen 
  
Thanks for your patience.  
  
We have fixed the reported issue “[UWP] Text color of the SfMaskedEdit is not applied” and the patch for the same can be downloaded from the below link.  
  
Please find the patch setup from the below location.  
or  
  
Please find the patch assemblies from the below location.  
or  
  
Please find the NuGet from the below location.  
 
Assembly Version: 17.1.0.38  
   
Disclaimer:  
   
Please note that we have created this patch for version 17.1.0.38 specifically to resolve the issue reported in the forum 143349. If you have received other patches for the same version for other products, please apply all patches in the order received. This fix will be included in our upcoming weekly NuGet release which is scheduled to be roll out in the mid of next week.  
   
Regards, 
Bharathi.



CONFIRMATION

This post will be permanently deleted. Are you sure you want to continue?

Sorry, An error occured while processing your request. Please try again later.

Please sign in to access our forum

This page will automatically be redirected to the sign-in page in 10 seconds.

Warning Icon You are using an outdated version of Internet Explorer that may not display all features of this and other websites. Upgrade to Internet Explorer 8 or newer for a better experience.Close Icon

;