We use cookies to give you the best experience on our website. If you continue to browse, then you agree to our privacy policy and cookie policy. (Last updated on: June 24, 2019).
Unfortunately, activation email could not send to your email. Please try again.
Syncfusion Feedback

Node Connector line Restrict to draw over new line connector to connect another node

Thread ID:

Created:

Updated:

Platform:

Replies:

143137 Mar 6,2019 06:09 AM UTC Mar 6,2019 12:25 PM UTC WinForms 3
loading
Tags: Diagram
Unknown
Asked On March 6, 2019 06:09 AM UTC

Hi,

Currently we are evaluating Syncfusion for Winform flow diagram now we are facing issue Node Connector line Restrict to draw over new line connector to connect another node.

For your reference i have attached screen shot with this mail.

Thanks in advance


Thanks & Regards,
Sumit

Attachment: ScreenShotRestrictLineConnectorOver_3ecabe1f.zip

Ramya Thirugnanam [Syncfusion]
Replied On March 6, 2019 09:36 AM UTC

Hi Sumit, 
 
We assumed that your issue is that line connector restricts or get highlighted when dragging one connector over another connector. Please disable “EnableCentralPort” property  of the LineConnector as false to resolve this. 
 
Please find the code example to disable this property. 
 
// it notifies when new node or connector get added in diagram 
this.diagram1.Model.EventSink.NodeCollectionChanged += EventSink_NodeCollectionChanged; 
 
  private void EventSink_NodeCollectionChanged(CollectionExEventArgs evtArgs) 
        { 
            if (evtArgs.Element is OrgLineConnector) 
            { 
                // To disbale coonector get connected with another connector 
                (evtArgs.Element as OrgLineConnector).EnableCentralPort = false; 
            }    
        } 
 
 
 
Regards, 
Ramya T 


Unknown
Replied On March 6, 2019 10:18 AM UTC

Hi Ramya,

Thanks for update

I have attached screen shot of exact  issue connecting to one node to another node with drawing tool while restrict another connector line to draw connector from source node to destination node.

Thanks & Regards,
Sumit

Attachment: ScreenShotRestrictLineConnectorOverNew_28bdc59d.zip

Ramya Thirugnanam [Syncfusion]
Replied On March 6, 2019 12:25 PM UTC

Hi Sumit,  
 
Thanks for your update.  
 
Please set EnableCentralPort property of the connector as false to resolve this behavior in your application. We have provided video to represent this. Please refer to the video from the below link. 
 
Video link:
restrictconnection
 
 
Regards, 
Ramya T 


CONFIRMATION

This post will be permanently deleted. Are you sure you want to continue?

Sorry, An error occured while processing your request. Please try again later.

Please sign in to access our forum

This page will automatically be redirected to the sign-in page in 10 seconds.

Warning Icon You are using an outdated version of Internet Explorer that may not display all features of this and other websites. Upgrade to Internet Explorer 8 or newer for a better experience.Close Icon

Live Chat Icon For mobile
Live Chat Icon