We use cookies to give you the best experience on our website. If you continue to browse, then you agree to our privacy policy and cookie policy. (Last updated on: June 24, 2019).
Unfortunately, activation email could not send to your email. Please try again.
Syncfusion Feedback

Including a parameter in a query which interrogates for equivalency (=) on a column of Data Type nvarchar(50) Allow Nulls = false is resulting in more than one result record when exactly one record should be returned.

Thread ID:

Created:

Updated:

Platform:

Replies:

142915 Feb 25,2019 10:14 PM UTC Mar 7,2019 05:24 AM UTC Report Platform 15
loading
Tags: Report Server
Amanpreet
Asked On February 25, 2019 10:15 PM UTC

Hi Team,


Problem Description:


Including a parameter in a query which interrogates for equivalency (=) on a column of Data Type nvarchar(50) Allow Nulls = false is resulting in more than one result record when exactly one record should be returned. 


Reproduction:


1)      In the syncfusion report server, create a new dataset from a datasource which contains a table with a nvarchar column with allow null set to false and all values in this column are unique


2)      In the visual designer, drag and drop the table with the nvarchar column with allow null set to false into the center window


3)      Click on the filter button


4)      Click the +Add button


5)      Select the nvarchar column with allow null set to false column


6)      Click the checkbox for Include as Parameter


7)      Click OK


8)      Click the slider for the code view


9)      Click the Run button


10)  Enter a string which exactly equals a unique value in the column


11) Click OK


12)  Verify that multiple columns are returned, one being a match for the where entered value and others which do not match


13)    Replace parameter in the where clause of the sql string with a hard-coded value equal to the value entered previously and click Run


14) Verify that only the one correct match is returned


Looking forward to see your response.


Regards,

Amanpreet


Mageshyadav M [Syncfusion]
Replied On February 26, 2019 12:44 PM UTC

Hi Amanpreet, 
 
We were unable to reproduce the mentioned issue at our end. Please find our testing steps and snaps as given below, 
 
Step 1: Create a new table with nvarchar column with allow null set to false in SQL management studio.   
 
 
 
Step 2: Insert column values. 
 
 
 
Step 3: Open Syncfusion report server, create a new dataset from a datasource which contains a table. Drag and drop the table with the nvarchar column with allow null set to false into the center window. 
 
 
 
Step 4: Add filter and click checkbox for the Parameter. And click ok button.  
 
 
 
Step 5: Click the slider for the code view. 
 
 
 
Step 6: Click Run button. Enter parameter values and click ok button. 
 
 
 
The data preview updated properly at our end. Can you please share the issue replicated video file to us. Also share us the snapshot of your table column details as shown in Step 1. This information will be helpful for us to determine the issue cause or provide solution at earliest. 
 
Regards, 
Mageshyadav.M 


Amanpreet
Replied On February 26, 2019 07:54 PM UTC

Hi team,

The steps have not been replicated correctly. The allow null checkbox should be unchecked as i mentioned in the query allow null = false.

I am highlighting the step which has been done wrong while replicating the issue-

Reproduction:


1)      In the syncfusion report server, create a new dataset from a datasource which contains a table with a

nvarchar column with allow null set to false (allow null checkbox should not be checked)and all values in this column are unique


2)      In the visual designer, drag and drop the table with the

nvarchar column with allow null set to false into the center window


3)      Click on the filter button


4)      Click the +Add button


5)      Select the nvarchar column with allow null set to false column


6)      Click the checkbox for Include as Parameter


7)      Click OK


8)      Click the slider for the code view


9)      Click the Run button


10)  Enter a string which exactly equals a unique value in the column


11) Click OK


12)  Verify that multiple columns are returned, one being a match for the where entered value and others which do not match


13)    Replace parameter in the where clause of the sql string with a hard-coded value equal to the value entered previously and click Run


14) Verify that only the one correct match is returned

Please verify and let me know whether you are able to replicate the issue or not.

Regards,
Amanpreet

Mageshyadav M [Syncfusion]
Replied On February 27, 2019 12:48 PM UTC

Hi Amanpreet,  
 
We were unable to reproduce the mention issue at our end. We would like to setup a web meeting to look on your side and provide solution. We have created an incident under your account to follow up meeting updates hence please log on to our support website to check for incident related to this forum.   
    
 
Regards, 
Mageshyadav.M 


Amanpreet
Replied On February 28, 2019 05:29 PM UTC

Hi team,

I have attached the screenshots in the zip.

Regards,
Amanpreet

Attachment: Not_null_column_issue_syncfusion_60c059f1.zip

Mageshyadav M [Syncfusion]
Replied On March 1, 2019 10:56 AM UTC

Hi Amanpreet, 
  
Still, with the details shared we are unable to reproduce the issue hence can you please share that table data to validate on our side. Also, we suspect for version we are testing. We have tested all your reported issues in latest version 3.2.0.40. Can you confirm the Report Server version you use ? 
  
Regards, 
Mageshyadav.M 


Amanpreet
Replied On March 1, 2019 03:09 PM UTC

Hi team,

I am using Report server version 3.1.0.33. I shall try to update and perform the same scenario. We are unable to share our table data. I am able to replicate the issue for any not null column parameter I choose.
Please try replicating on the version I am using.
Please check if you can replicate the same issue on your end.

Regards,
Amanpreet

Amanpreet
Replied On March 1, 2019 04:39 PM UTC

Hi team,

I want to upgrade report server syncfusion to latest version but I don't intend to loose my data like the datasources, datasets and reports I have already created. Please let me know how I can upgrade without impacting my work.

Regards,
Amanpreet

Mageshyadav M [Syncfusion]
Replied On March 4, 2019 06:20 AM UTC

Hi Amanpreet, 
 
You can upgrade the Report Server from v3.1.0.33 to latest v3.2.0.40 without losing your data.  
 
As we have looked into your previous forums/incidents, we hope that you are using the Report Server on-premise(.exe installer) build for production deployment. If so, you can upgrade the Report Server by following the steps in the below help link,  
 
If you are looking for upgrade the Azure app service, please follow the steps in the below help link,  
 
Regards, 
Mageshyadav.M 


Amanpreet
Replied On March 4, 2019 09:03 PM UTC

Hi Team,

I am trying to upgrade Syncfusion and I am having difficulties. Originally I deployed Syncfusion as an application and when I try to install/upgrade to the same location and port number there is error "The given port number is reserved by another site. Please try another port number"

Please help me resolving this issue.

Regards,
Amanpreet

Mageshyadav M [Syncfusion]
Replied On March 5, 2019 07:06 AM UTC

Hi Amanpreet,  
 
The port number which you have provided during installing the Report Server is maintained in the below location,  
C:\Program Files (x86)\Syncfusion\Report Server\Utilities\InstallInfoGenerator\InstallInfo.XML  
 
If you have provided the port no other than the previously provided one, the installer would consider it as other app and it returns the error message as you have provided.  
 
To continue with your preferred port no, we request you to change the port number as below in the above mentioned XML file,  
 
  
 
Please let us know if you need further assistance on it. 
 
Regards, 
Mageshyadav.M 


Amanpreet
Replied On March 5, 2019 02:32 PM UTC

Hi team,

Thank you for the response I am able to upgrade.

Can you please let me know how to find out what is the version of the instance of syncfusion report server I am running?

Regards,
Amanpreet

Amanpreet
Replied On March 5, 2019 03:31 PM UTC

Hi team,

I have upgraded to the latest version but the issue is still reproducible. Can we schedule another support call so that I am able to demonstrate the issue better?

Regards,
Amanpreet

Mageshyadav M [Syncfusion]
Replied On March 6, 2019 11:25 AM UTC

Hi Amanpreet, 
 
Please find the response for your queries. 
 
Query 
Response 
Thank you for the response I am able to upgrade. 
 
Can you please let me know how to find out what is the version of the instance of syncfusion report server I am running? 
 
You can find the current version of the deployed Syncfusion Report Server in any of the following ways,  
   
  1. From the control panel :
Go to the below location in your system,  
 
Control Panel\Programs\Programs and Features  
 
Search for ‘syncfusion report server’ and the highlighted part in the below image is the version of Report Server.  
 
    
  1. From database:
Connect to the database you used for deploying Syncfusion Report Server and run the below query.  
Note: We placed the screenshots of SQL server.  
 
    
  1. From deployed location of Report Server.
 Select the database folder that you used for deploying the Syncfusion Report Server from the highlighted location in the below image.  
     
 
Go to the below mentioned location.  
 
    
 
Open the below highlighted file with the notepad.  
 
                 
Find the node with value ‘’latest.sql”  
 
            
 
I have upgraded to the latest version but the issue is still reproducible. Can we schedule another support call so that I am able to demonstrate the issue better? 
Please share your available date and time in incident created under your account related to this forum so that we can schedule the meeting and update the meeting link in incident. 
 
Regards, 
Mageshyadav.M 


Amanpreet
Replied On March 6, 2019 02:07 PM UTC

Hi team,

I am available from 8.30 AM CST till EOD Monday through Friday.

Regards,
Amanpreet

Mageshyadav M [Syncfusion]
Replied On March 7, 2019 05:24 AM UTC

Hi Amanpreet, 
  
We will schedule and share the meeting link in incident which has been created related to this forum. 
  
Regards, 
Mageshyadav.M 


CONFIRMATION

This post will be permanently deleted. Are you sure you want to continue?

Sorry, An error occured while processing your request. Please try again later.

Please sign in to access our forum

This page will automatically be redirected to the sign-in page in 10 seconds.

Warning Icon You are using an outdated version of Internet Explorer that may not display all features of this and other websites. Upgrade to Internet Explorer 8 or newer for a better experience.Close Icon

Live Chat Icon For mobile
Live Chat Icon