We use cookies to give you the best experience on our website. If you continue to browse, then you agree to our privacy policy and cookie policy. (Last updated on: June 24, 2019).
Unfortunately, activation email could not send to your email. Please try again.
Syncfusion Feedback

SfListView content is not displayed correctly when FrontLayer is concealed(minimized) + Events handled by the page

Thread ID:

Created:

Updated:

Platform:

Replies:

142906 Feb 25,2019 04:13 PM UTC Feb 26,2019 09:48 AM UTC Xamarin.Forms 1
loading
Tags: SfBackdropPage
Konstantinos Skoularikis
Asked On February 25, 2019 04:13 PM UTC

Hello,

I am using SfBackdropPage control in order to create the content needed for the main page of my application. The main page does not have a navbar or hamburger menu icon. 
In the BackdropFrontLayer there is a SfListView of users and a searchbar and in the BackdropBackLayer there is my map intergration.
Problems that I have:
1) When FrontLayer is minimized, the last cells of the SfListView are not visible when scrolling (I think due to the traslationX implemented).
2) I cant use any swipe gesture on the FrontLayer
3) Need clarification on the events used by the FrontLayer in order to enhance its usability by adding my own events.

Thank you very much 

Bharathiraja K [Syncfusion]
Replied On February 26, 2019 09:48 AM UTC

Hi Konstantinos, 
 
Greetings from Syncfusion. Please find the response for your query below here. 
 
For Query 1, List view item visibility  
We have tried to replicate the reported issue at our end by creating a simple sample, we are afraid that we are not able to reproduce the issue at our end.  
 
So, can you please revert us by modifying the sample based on your application along with replication procedure. This will be helpful for us to investigate further and provide you a better solution at the earliest. 
 
For Query 2 and 3, Swipe gestures and related events. 
We would like to inform you that  interactions at top region (up to RevealedHeight)  of the front layer will be handled by backdrop control for swipe support to reveal or conceal the back layer.  
    
You can resolve this by disabling swiping action for revealing/concealing back layer by setting false for EnableSwiping property of Frontlayer and using header icon for revealing/concealing back layer.    
  
Please refer the below code snippet.   
Code Snippet [XAML]    
<backdrop:BackdropFrontLayer EnableSwiping="False">   
      <!--Your code for list view here-->  
</backdrop:BackdropFrontLayer>   
    
 
If the provided solution doesn’t meet your requirement, kindly revert us back with more information to replicate your scenario along with code snippets or sample.  
 
 
Regards, 
Bharathi. 


CONFIRMATION

This post will be permanently deleted. Are you sure you want to continue?

Sorry, An error occured while processing your request. Please try again later.

Please sign in to access our forum

This page will automatically be redirected to the sign-in page in 10 seconds.

Warning Icon You are using an outdated version of Internet Explorer that may not display all features of this and other websites. Upgrade to Internet Explorer 8 or newer for a better experience.Close Icon

Live Chat Icon For mobile
Live Chat Icon