We use cookies to give you the best experience on our website. If you continue to browse, then you agree to our privacy policy and cookie policy. (Last updated on: November 16, 2018).
Unfortunately, activation email could not send to your email. Please try again.
Syncfusion Feedback

RE: Spark-Shell Issue

Thread ID:

Created:

Updated:

Platform:

Replies:

141882 Jan 9,2019 12:46 PM UTC Jan 11,2019 04:32 AM UTC Big Data Platform 2
loading
Tags: Big Data Studio
Venkatesh
Asked On January 9, 2019 12:46 PM UTC

Hi,

This is Venkatesh and I've been using your product for my hadoop and spark hands on practises on windows. I've to say, it is very helpful. Really cool integration of all hadoop tools into a unified platform.

But, lately have been experiencing issues with running scala commands in spark shell. Interestingly, I opened pyspark, and there it works perfectly.

Even a 1+1 command on a spark shell takes a while to execute, when I type enter, it enters character by character and takes so long to execute.

Tried manipulating executor cores and memory and nothing seem to work.

It'd be very helpful if you can take a look into the issue.

My email id is rambo.saimukunth@gmail.com

Thanks,
Venkatesh Raman

Boomigha Velayutham [Syncfusion]
Replied On January 10, 2019 12:11 PM UTC

Hi Venkatesh, 

Thanks for using our Syncfusion products. 

Letters slowly getting typed scenario in Spark-Scala console occurs only in Windows 10 operating system. On checking the same, we would suggest to upgrade “jline” jar to latest one(2.14.6) in your Spark package. Can you please do the below steps to ensure that the issue gets resolved at your end? 

Steps: 

Step 1: Download the 2.14.6 version of jline jar from below location: 

Step 2: Stop all the services (Refer below screenshot) 
                                  

Step 3: Replace the downloaded jar “jline-2.14.6” instead of “jline-2.12.1” in Spark Jars folder(..\Syncfusion\BigData\3.2.0.20\BigDataSDK\SDK\Spark\jars\jline-2.12.1). 

Step 4: Now start the services and make use of scala/pyspark. (Refer below screenshot) 
                                 

Please let us know, if you have any other concerns. 

Thanks, 
Boomigha 


Pon Geetha A J [Syncfusion]
Replied On January 11, 2019 04:32 AM UTC

Thanks for your timely help. The problem is solved. Really appreciate it 😊 


CONFIRMATION

This post will be permanently deleted. Are you sure you want to continue?

Sorry, An error occured while processing your request. Please try again later.

Please sign in to access our forum

This page will automatically be redirected to the sign-in page in 10 seconds.

Warning Icon You are using an outdated version of Internet Explorer that may not display all features of this and other websites. Upgrade to Internet Explorer 8 or newer for a better experience.Close Icon

;