We use cookies to give you the best experience on our website. If you continue to browse, then you agree to our privacy policy and cookie policy. Image for the cookie policy date

Color_Change Error

I'm receiving the error below while loading my report into the viewer. Any insights?

_reportLoaded:Sf_Exception - System.Exception: An error occurred during local report processing. There is an error on line 0 of custom code: BC30451: 'Color_Change' is not declared. It may be inaccessible due to its protection level. at Syncfusion.RDL.Data.ReportModel.ProcessReport() at Syncfusion.EJ.ReportViewer.Internal.ReportViewerLayoutModel.LoadReport() at Syncfusion.EJ.ReportViewer.Internal.ReportViewerInternalHelper.ReportLoad() at Syncfusion.EJ.ReportViewer.Internal.ReportViewerInternalHelper.ProcessReport()

7 Replies

MM Mageshyadav M Syncfusion Team January 8, 2019 05:31 AM UTC

Hi Lance, 

We are unable to reproduce the mentioned exception at our end. So can you please share the issue reproducible RDL file, index.cshtml client file and ReportAPIController class file to validate the mentioned problem at our end. Also share us the release version you are using. 

Regards, 
Mageshyadav.M 



LH Lance Harwell January 8, 2019 02:13 PM UTC

I am attaching the .cshtml and the controller. I'm calling a remote SSRS so providing the RDL could be a challenge.

Attachment: Files_90701eb1.zip


LH Lance Harwell January 8, 2019 02:19 PM UTC

I'm running release 16.1450.0.24. I've just determined that "Color_Change" is custom code in the report itself. This report runs in other instances but this is the only one that seems to have any issues.


LH Lance Harwell January 8, 2019 02:38 PM UTC

I've updated the zip from earlier to include the report definition.

Attachment: Files_710e5e7.zip


MM Mageshyadav M Syncfusion Team January 9, 2019 07:32 AM UTC

Hi Lance, 
 
Thanks for sharing the report. We have checked your report in that you are getting the value for Set_Color method from Color_Change method in code modules. But in our previous version nested methods code modules are not working. We have already fixed this issue in our updated source and this changes will be reflected in 2018 Volume 4 SP1 release which can be expected to be rolled out by end of January 2019. 
 
Regards, 
Mageshyadav.M 



LH Lance Harwell February 21, 2019 03:25 AM UTC

I have now updated to version 16.4450.0.52 and the error I was getting has gone away. I'm no longer getting any errors and the viewer itself loads; however, the report never loads into the viewer. I only get the spinning loading icon that never goes away.


MM Mageshyadav M Syncfusion Team February 21, 2019 02:06 PM UTC

Hi Lance, 
 
Can you please confirm whether the mentioned issue occurred in your shared report in the previous update (or) you are using modified report. If you are using modified report, can you please share the report and also share the console error details, if exist. It will be helpful for us to determine the issue cause or provide solution at earliest. 
 
Regards, 
Mageshyadav.M 


Loader.
Live Chat Icon For mobile
Up arrow icon