We use cookies to give you the best experience on our website. If you continue to browse, then you agree to our privacy policy and cookie policy. Image for the cookie policy date

EJ2 Grid Paging Skip and Take not sent

Hello

I am using EJ 2 version 16.3.0.36 (nuget package).

I have a grid with remote data (UrlAdaptor). The grid uses paging.

The paging is defined as follows:

...
.AllowPaging().PageSettings(page =>
{
    page.PageSizes(true);
})
...


However, when I change the records per page dropdown in the grid, the server always receives the same number in dm.Take, the changes on the client are not sent to the server.

This seems to have worked some releases ago.

Do you have any idea why this code does not work?


Kind regards
Phil

3 Replies

VA Venkatesh Ayothi Raman Syncfusion Team December 11, 2018 11:27 AM UTC

Hi Phil, 

Thanks for contacting Syncfusion support. 

We have analyzed your query. We have tried to reproduce the reported problem by creating an “UrlAdaptor” sample and enabling paging in Grid with pager drop down. But we could not reproduce the reported problem. The “dm.take” returns proper values as selected in the drop down. The below screenshot is a result of selecting the value “5” from the drop down. 

 

We have also attached the sample for your convenience, please download it from the link below, 
 
If you are still facing the issue, please get back to us with the following details, 
  1. Share the exact scenario/proper replication procedure.
  2. Share with us the Grid code and server side code.
  3. Share with us the Essential Studio script version you are using.
 
The provided information will help us analyze the problem, and provide you a solution as early as possible. 

Regards, 
Venkatesh Ayothiraman. 



PH Phil December 12, 2018 03:04 PM UTC

The whole thing is quite strange.
I used a default grid with only the pagination enabled and it just did not want to work.
On the client side the pagination worked as it should (display of pages, results per page, etc.) on the server side the dm.Take and dm.Skip properties were always the default values.

However, when I tried again today, without changing any single line of code, it all worked correctly...
Thus the issue has resolved itself.
I am truly grateful for your help, at a complete loss as to why it works now and sorry for the inconvenience.


MF Mohammed Farook J Syncfusion Team December 13, 2018 07:38 AM UTC

Hi Phil, 
 
Thanks for your update. 
 
We are happy to hear that the provided solution has been resolved your problem. 
 
Please get back to us if you need further assistance. 
 
Regards 
J Mohammed Farook 
 


Loader.
Live Chat Icon For mobile
Up arrow icon