We use cookies to give you the best experience on our website. If you continue to browse, then you agree to our privacy policy and cookie policy. (Last updated on: June 24, 2019).
Unfortunately, activation email could not send to your email. Please try again.
Syncfusion Feedback

Picker and Orientation issue

Thread ID:

Created:

Updated:

Platform:

Replies:

141233 Nov 30,2018 10:28 AM UTC Mar 14,2019 12:39 PM UTC Xamarin.Forms 5
loading
Tags: SfPicker
Dan Dumitrascu
Asked On November 30, 2018 10:28 AM UTC

Hi,

1. My device is in portrait mode. I open a picker.
2. I change the orientation to landscape. The picker is not in the center of the parent view (even if I set VerticalOptions and HorizontalOptions to Center). It preserves the X position.


Is there any solution for this?

Attachment: PickerScreens_9a6cd2fc.zip

Paul Anderson S [Syncfusion]
Replied On November 30, 2018 11:33 AM UTC

Hi Dan Dumitrascu, 
 
Greetings from Syncfusion. 
 
We are able to reproduce the reported issue “When rotating the device, the picker is not in the centered to its parent view” from our side and we have logged a bug report for the reported issue. The fix will be available in our upcoming Volume 4 SP1 release which will be in the end of January 2019. 
 
Regards, 
Paul Anderson 


Dan Dumitrascu
Replied On November 30, 2018 11:37 AM UTC

Thank you,
As a workaround until then:
The picker must be removed from the parent view, disposed, recreated and added back when the orientation change is detected.

Paul Anderson S [Syncfusion]
Replied On November 30, 2018 11:41 AM UTC

Hi Dan Dumitrascu, 
 
Thanks for the update. 
 
We are glad that you have got the workaround for the reported issue with SfPicker. We can use the suggested workaroud. As mentioned earlier we will fix and will be available in our upcoming Volume 4 SP1 release which will be in the end of January 2019. 
 
Regards, 
Paul Anderson 


Giorgi Dalakishvili
Replied On March 13, 2019 07:58 AM UTC

Is there any fix on this issue?

Dhanasekar R [Syncfusion]
Replied On March 14, 2019 12:39 PM UTC

Hi Giorgi,       
             
Yes. The fix has been fixed in NuGet version 16.4.0.54. So, please use our upgraded NuGet version in your application to resolve this problem.        
   
Please get back to us if you are still facing the problem in latest version.   
       
Regards,       
Dhanasekar    


CONFIRMATION

This post will be permanently deleted. Are you sure you want to continue?

Sorry, An error occured while processing your request. Please try again later.

Please sign in to access our forum

This page will automatically be redirected to the sign-in page in 10 seconds.

Warning Icon You are using an outdated version of Internet Explorer that may not display all features of this and other websites. Upgrade to Internet Explorer 8 or newer for a better experience.Close Icon

Live Chat Icon For mobile
Live Chat Icon