We use cookies to give you the best experience on our website. If you continue to browse, then you agree to our privacy policy and cookie policy.
Unfortunately, activation email could not send to your email. Please try again.

Syncfusion 2.0.5 And Installshield

Thread ID:

Created:

Platform:

Replies:

13964 May 14,2004 04:45 AM General Discussion 0
loading
Tags: General Discussion
Conrad Rowlands
Asked On May 14, 2004 04:45 AM

We went through all the usual problems that everyone describes when talking about the licensing issue regarding Sf 2.0.5.(Upgrading from 1.6.1) We now have sorted this out but are left with one problem. We have an installation process created using Installshield 8.0. This has been working fine for months now and I know it is a bit of cliche to say that nothing has changed but this is true. The installation itself has not changed and neither has the version of installshield used to compile the install. One of our ''Components'' using installshield terminology is a .NET installer class that upon running will create and populate a database and get the app ready for use etc. A portion of the installer class code is running before being halted by the following exception error 1001. File or Assembly name Syncfusion.Shared or one of it''s dependancies was not found. At this point it is we believe trying to load an assembly that has a reference to the Syncfusion Progress Bar. Our problem is this, The directory that the application is running in does contain all of the dependancies required for the app So we thought that maybe using the ''home directory'' of the install might force this to work so we decided to add the files here as well. Too late they already were. As a last resort we put the three SF files into the GAC. Lo and behold the installation then worked. In addition to the above (before we added the SF files to the GAC) we invoked the app directly using a test executable from the installation directory and it worked without any problem. I can certainly see that point of view that SF are maybe doing nothing incorrectly as has been proven by the very fact that we managed to invoke the app directly. However you have implemented a change that in the real world has maybe broken some users installations. I can also see the point that it is probably installshield who are at fault in this instance. For now we will use the GAC to get around our problems which is not, for us, ideal. Is there any chance that this problem will be addressed or looked into?

CONFIRMATION

This post will be permanently deleted. Are you sure you want to continue?

Sorry, An error occured while processing your request. Please try again later.

You are using an outdated version of Internet Explorer that may not display all features of this and other websites. Upgrade to Internet Explorer 8 or newer for a better experience.

;