We use cookies to give you the best experience on our website. If you continue to browse, then you agree to our privacy policy and cookie policy.
Unfortunately, activation email could not send to your email. Please try again.

Error when re-entering page - UWP

Thread ID:

Created:

Updated:

Platform:

Replies:

132833 Sep 24,2017 06:55 AM Sep 27,2017 05:37 AM Xamarin.Forms 3
loading
Tags: SfDigitalGauge
DukeMeister
Asked On September 24, 2017 07:02 AM

I'm not 100% sure this is a problem with SfDigitalGauge. I have a cross-platform PCL app and the problem is occurring when I run the UWP version. I have a page with several SfDigitalGauges and also an SfDataGrid and some simple labels. I'm arranging contents with stacklayouts and grids. 

The first time into the page everything is ok, but if I navigate to another page (I have 5 tabbed pages of which this one is 2nd in order) and come back into it, I get the following error.

{System.NullReferenceException: Object reference not set to an instance of an object.
   at Xamarin.Forms.Platform.UWP.ImageRenderer.UpdateAspect()
   at Xamarin.Forms.Platform.UWP.ImageRenderer.d__3.MoveNext()
--- End of stack trace from previous location where exception was thrown ---
   at System.Runtime.CompilerServices.AsyncMethodBuilderCore.<>c.b__6_0(Object state)
   at System.Threading.WinRTSynchronizationContext.Invoker.InvokeCore()}

I know it's vague at this stage but I was wondering if this gave any immediate clues.

My UWP app MainPage constructor looks like this:

        public MainPage()
        {
            SfDataGridRenderer.Init();
            SfListViewRenderer.Init();
            this.InitializeComponent();

            LoadApplication(new App1.App());
        }

The Android version runs fine in an emulator. I'm running the UWP version on the local machine as the simulator gives me BSOD's.

Please let me know what more info I can provide. Thanks.

edit: ok I managed to get a run on the Simulator, with the same result.

edit 2: Just realized it's in a Xamarin.Forms DLL but anyway I'll leave this here and also post something on the Xamarin forum.


Ashwin Kumaravel [Syncfusion]
Replied On September 25, 2017 08:30 AM

Hi Tino,

Thanks for using Syncfusion products,

We have validated your query and we have found that the reported issue is getting reproduced when we are using Image view in Xaml pages with Xamarin Forms older versions. This is a known issue and reported in Bugzilla community. Can you please ensure whether you are using latest Xamarin Forms packages or please update to latest version to overcome from this issue?

The same problem is already reported in Bugzilla and please check the below link,

Link- https://bugzilla.xamarin.com/show_bug.cgi?id=37022

Please get back to us if you have any concern,

Regards,
Ashwin


DukeMeister
Replied On September 26, 2017 08:14 AM

EDIT: Well, I installed  pre-release version 2.4.0.275-pre3, and I no longer have the crashing problem.. For now I'll stick with this.


ORIGINAL POST:

Nuget is not telling me of any updates. As far as I can tell I'm up to date.

I'm using xamarin.forms 2.3.4.270

My portable project packages:


My UWP packages:



Ashwin Kumaravel [Syncfusion]
Replied On September 27, 2017 05:37 AM

Hi Tino,

We are glad to know that you have met your requirement. Please let us know if you have any queries.

Regards,
Ashwin.k
 


CONFIRMATION

This post will be permanently deleted. Are you sure you want to continue?

Sorry, An error occured while processing your request. Please try again later.

You are using an outdated version of Internet Explorer that may not display all features of this and other websites. Upgrade to Internet Explorer 8 or newer for a better experience.

;