We use cookies to give you the best experience on our website. If you continue to browse, then you agree to our privacy policy and cookie policy. (Last updated on: November 16, 2018).
Unfortunately, activation email could not send to your email. Please try again.
Syncfusion Feedback

Disable click on GridControl Column

Thread ID:

Created:

Updated:

Platform:

Replies:

131479 Jul 12,2017 05:24 AM UTC Jul 14,2017 04:03 AM UTC WinForms 3
loading
Tags: GridControl
JeeNew
Asked On July 12, 2017 05:24 AM UTC

Hi,

I have a gridControl with 1 Column. I have used the column as a multiline column to enter two sets of data, one below another using Environment.NewLine.

For Example

-----------------------------------
Row | Details
-----------------------------------
1      | a
        | b
-----------------------------------
2      | a
        | b
-----------------------------------

If I click on a row, the focus changes and I can see only the second line (i.e., b) and an empty line instead of the first line (a) and second line (b) as shown below

-----------------------------------
Row | Details
-----------------------------------
1       | b
         | <Empty Line>
-----------------------------------
2      | a
        | b
-----------------------------------

Is there a way to disable the click so that when I click on the column it does not change its view?

Thanks in advance!

Arulpriya Ramalingam [Syncfusion]
Replied On July 13, 2017 07:30 AM UTC

Hi Jeevan,  
 
Thanks for using Syncfusion products.  
 
In order to disable the CellClick behavior, you can set the ActivateCurrentCellBehavior property as None. Please make use of the below code example and sample,  
 
Code example   
  
  
//To disable the currentcellbehavir when click on the cell  
this.gridControl1.ActivateCurrentCellBehavior =GridCellActivateAction.None;  
  
  
  
Note  
If you want to disable the cell editing mode, you can set ReadOnly or BrowseOnly property to GridControl. Please refer to the UG links to know more about ReadOnly and BrowseOnly 
  
 
Regards,  
Arulpriya 

JeeNew
Replied On July 13, 2017 10:36 PM UTC

Hi ArulPriya,

Thanks a lot. It fixed my issue.

Regards,

Jeevan


Arulpriya Ramalingam [Syncfusion]
Replied On July 14, 2017 04:03 AM UTC

Hi Jeevan,   

We are glad to hear that the provided solution is resolved your scenario.   

Please let us know if you need further assistance.    
   
Regards,   
Arulpriya 


CONFIRMATION

This post will be permanently deleted. Are you sure you want to continue?

Sorry, An error occured while processing your request. Please try again later.

Warning Icon You are using an outdated version of Internet Explorer that may not display all features of this and other websites. Upgrade to Internet Explorer 8 or newer for a better experience.Close Icon

;