We use cookies to give you the best experience on our website. If you continue to browse, then you agree to our privacy policy and cookie policy.
Unfortunately, activation email could not send to your email. Please try again.

how to auto-wrap long text field in column in grid

Thread ID:

Created:

Updated:

Platform:

Replies:

130965 Jun 13,2017 09:40 PM Jun 14,2017 03:29 AM ASP.NET MVC 1
loading
Tags: Grid
Dongil Shin
Asked On June 13, 2017 09:40 PM

Hi, I need to auto-wrap in case of long text in a column in grid.

as attached screenshots, the bootstrap table can autowrap the long text (like multiple lines), 
however in the syncfusion grid, it cannot show either the whole long text or not multiple lines(height needs to be increased automatically) in a column.

Could you give me an idea?

Thank you.
Kind Regards,

Attachment: auto_wrapping_notok_50e8ae38.zip

Venkatesh Ayothi Raman [Syncfusion]
Replied On June 14, 2017 03:29 AM

Hi Dongil, 

Thanks for contacting Syncfusion support. 

We have built-in support of text trap feature for your requirement. If we enable the AllowTextWrap feature in Grid, then content will wrap to the next line when the content exceeds the boundary of the column cells width.  

Please refer to the following Help documentation and code example for more information, 


Code example
@(Html.EJ().Grid<Object>("FlatGrid") 
            .Datasource((IEnumerable<object>)ViewBag.DataSource) 
            .AllowPaging() 
 
            .AllowTextWrap() 
            .TextWrapSettings(wrap => { wrap.WrapMode(WrapMode.Both); }) 
 
            .Columns(col => 
            { 
                   . . . 
            })) 
 

Please let us know if you have any further assistance on this. 

Regards, 
Venkatesh Ayothiraman. 


CONFIRMATION

This post will be permanently deleted. Are you sure you want to continue?

Sorry, An error occured while processing your request. Please try again later.

You are using an outdated version of Internet Explorer that may not display all features of this and other websites. Upgrade to Internet Explorer 8 or newer for a better experience.

;