We use cookies to give you the best experience on our website. If you continue to browse, then you agree to our privacy policy and cookie policy.
Unfortunately, activation email could not send to your email. Please try again.

Chart disappears when clicking on legend items, IF using custom label template.

Thread ID:

Created:

Updated:

Platform:

Replies:

130508 May 16,2017 08:38 AM May 22,2017 12:39 AM JavaScript 5
loading
Tags: ejChart
Alexandru Boboc
Asked On May 16, 2017 09:47 AM

Hi,I'm trying to use a pie chart with custom label template, as per your examples, but I've encountered this issue: when clicking on a legend element (all except the last one), the chart is dissapearing.I've used jsplayground to make a demo with this issue:http://jsplayground.syncfusion.com/ujte1nojAny idea on how to fix this?Thanks, Alex

Alexandru Boboc
Replied On May 16, 2017 09:47 AM

Found this related error in console:

    ERROR TypeError: Cannot read property 'style' of undefined
    at r.drawLabelTemplate (http://localhost:3000/ej.web.all.min.js:10:7347180)
    at r.drawDataLabelAcc (http://localhost:3000/ej.web.all.min.js:10:7331947)
    at Object.drawAccDisplayText (http://localhost:3000/ej.web.all.min.js:10:7508738)
    at Object._animationElements (http://localhost:3000/ej.web.all.min.js:10:7462193)
    at Object._accSeriesDraw (http://localhost:3000/ej.web.all.min.js:10:7464408)
    at Object.seriesRender (http://localhost:3000/ej.web.all.min.js:10:7466423)
    at Object.draw (http://localhost:3000/ej.web.all.min.js:10:7447290)
    at Object._doClick (http://localhost:3000/ej.web.all.min.js:10:7576613)
........................

Alexandru Boboc
Replied On May 16, 2017 09:49 AM

I'm re-posting the original post, since when trying to edit it, the formatting seems to go all nuts.

Hi,

I'm trying to use a pie chart with custom label template, as per your examples, but I've encountered this issue: when clicking on a legend element (all except the last one), the chart is dissapearing.

I've used jsplayground to make a demo with this issue:
http://jsplayground.syncfusion.com/ujte1noj

Any idea on how to fix this?

Thanks,

Alex

Dharanidharan Dharmasivam [Syncfusion]
Replied On May 18, 2017 09:52 AM

Hi Alexandru, 

Sorry for the inconvenience. 

We can able to reproduce the reported issue, so we have logged issue report for your query. Fix for the reported issue will be available on volume 2 SP 1 release, which is expected to be out in the end of May 2017.  

Thanks, 
Dharani. 


Alexandru Boboc
Replied On May 19, 2017 09:29 AM

Thank you. 

Dharanidharan Dharmasivam [Syncfusion]
Replied On May 22, 2017 12:39 AM

Hi Alexandru, 
 
Thanks for your update. As stated in our previous update, fix for the reported issue will be available on volume 2 SP 1 release, which is expected to be out in the end of May 2017. 
  
Thanks, 
Dharani. 


CONFIRMATION

This post will be permanently deleted. Are you sure you want to continue?

Sorry, An error occured while processing your request. Please try again later.

You are using an outdated version of Internet Explorer that may not display all features of this and other websites. Upgrade to Internet Explorer 8 or newer for a better experience.

;