We use cookies to give you the best experience on our website. If you continue to browse, then you agree to our privacy policy and cookie policy. (Last updated on : Nov 16th 2018).
Unfortunately, activation email could not send to your email. Please try again.
Syncfusion Feedback

show-weekend attribute is not working

Thread ID:

Created:

Updated:

Platform:

Replies:

130451 May 14,2017 12:23 AM UTC May 16,2017 05:18 AM UTC ASP.NET Core 3
loading
Tags: Schedule
dsapo
Asked On May 14, 2017 12:23 AM UTC

Hi Support:

I just installed the latest version (15.2600.0.40) to try the show-weekend attribute in the schedule control, but the weekends are shown.

In my view I have this:

<ej-schedule id="myCalendar" width="100%" height="525px" show-quick-window="false" current-date="DateTime.Now"
             time-zone="@ViewData["TimeZone"]" show-time-zone-fields="false" current-view="Month" show-weekend="false"
             show-all-day-row="true"
             navigation="onNavigation"
             action-complete="onComplete"
             start-hour="8" end-hour="17"
             read-only="true"
             is-dst="true"
             views="@views" appointment-window-open="onAppointmentWindowOpen">
    <e-time-scale enable="false"></e-time-scale>
    <e-appointment-settings id="ID" subject='"Subject"' start-time='"StartTime"' end-time='"EndTime"'
                            start-time-zone='"StartTimeZone"' end-time-zone='"EndTimeZone"'
                            all-day='"AllDay"' recurrence='"Recurrence"' recurrence-rule='"RecurrenceRule"'>

        <e-datamanager url="GetData" adaptor="UrlAdaptor"></e-datamanager>

    </e-appointment-settings>

</ej-schedule>

What could I be missing here.

Thanks in advance.

David

Sellakumar [Syncfusion]
Replied On May 15, 2017 05:41 PM UTC

Hi David, 
 
Thanks for contacting Syncfusion support. 
 
With the provided code snippet, we have created and checked a new sample with the reported issue on show-weekend property – but we were unable to reproduce the it at our end. We also suspect that the browser cookies in your machine is not cleared properly and therefore we kindly request you to try clearing it once before running the project.  
 
The weekends are hidden on the Scheduler using this property show-weekend=”false” which can be viewed from the below downloadable sample link –  
 
 
If the problem still exists at your end, kindly try to reproduce the issue on the above provided sample link and revert us to proceed further on it. 
 
Regards, 
Sellakumar K 


dsapo
Replied On May 15, 2017 07:21 PM UTC

Thank Sellakumar, I cleared the cookies in Chrome and is working as expected.

Regards,

David 

Karthigeyan Krishnamurthi [Syncfusion]
Replied On May 16, 2017 05:18 AM UTC

Hi David,  
 
We are happy that your issue has been resolved.  
 
Regards, 
Karthigeyan 


CONFIRMATION

This post will be permanently deleted. Are you sure you want to continue?

Sorry, An error occured while processing your request. Please try again later.

Warning Icon You are using an outdated version of Internet Explorer that may not display all features of this and other websites. Upgrade to Internet Explorer 8 or newer for a better experience.Close Icon

;