We use cookies to give you the best experience on our website. If you continue to browse, then you agree to our privacy policy and cookie policy.
Unfortunately, activation email could not send to your email. Please try again.
Syncfusion Feedback

PieChart and DonutChart not rendering with SmartLabels enabled

Thread ID:

Created:

Updated:

Platform:

Replies:

129808 Apr 4,2017 08:38 PM UTC Apr 10,2017 12:20 PM UTC Xamarin.Forms 3
loading
Tags: SfChart
Stefano Passatordi
Asked On April 4, 2017 08:38 PM UTC

Hi,

I've just updated to the latest version 15.1.0.41 (Xamarin Forms version 2.3.3.193) and pie charts and donut charts do not render anymore on Android when smartlabels are enabled.
If I set EnableSmartLabels = false then charts are rendered again.

Can you help?

Thanks,
Stefano

Divya Venkatesan [Syncfusion]
Replied On April 5, 2017 05:43 PM UTC

Hi Stefano,

We are not able to reproduce the reported issue at our end and we have prepared a sample for this. Please download the sample from following location.

Sample: http://www.syncfusion.com/downloads/support/forum/129808/ze/PieChart2050356114

Please update us the modified sample to reproduce the issue which will be helpful for providing further assistance on this.

Regards,
Divya Venkatesan


Stefano Passatordi
Replied On April 8, 2017 04:50 PM UTC

Hi,

Thanks for the example code. Now it works, looks like I need to set  DataMarkerPosition="OutsideExtended" to make smart labels work.

This is my code:

   PieSeries series = new PieSeries()
            {
                ItemsSource = pieSeries,
                DataMarker = new ChartDataMarker()
                {
                    LabelContent = LabelContent.Percentage,
                    ShowLabel = true
                },
                DataMarkerPosition = CircularSeriesDataMarkerPosition.OutsideExtended,
                EnableTooltip = true,
                EnableSmartLabels = true,
                CircularCoefficient = 0.8,
                ExplodeOnTouch = true
            };

I don't have the chart into xaml page, I inject it dynamically by code. Maybe this makes the difference. Anyway, setting DataMarkerPosition fixed the issue.

Thanks,
Stefano 

Divya Venkatesan [Syncfusion]
Replied On April 10, 2017 12:20 PM UTC

Hi Stefano,

Thanks for the update.

We are not able to reproduce the issue even while setting DataMarkerPosition to Inside / Outside.

However we are glad to know that your issue has been resolved by setting DataMarkerPosition to OutsideExtended.

Please get back to us if you have any concerns in this.

Regards,
Divya Venkatesan


CONFIRMATION

This post will be permanently deleted. Are you sure you want to continue?

Sorry, An error occured while processing your request. Please try again later.

Warning Icon You are using an outdated version of Internet Explorer that may not display all features of this and other websites. Upgrade to Internet Explorer 8 or newer for a better experience.Close Icon

;