We use cookies to give you the best experience on our website. If you continue to browse, then you agree to our privacy policy and cookie policy.
Unfortunately, activation email could not send to your email. Please try again.

sfDataGrid drastically slowed down

Thread ID:

Created:

Updated:

Platform:

Replies:

129276 Mar 9,2017 03:24 AM Mar 10,2017 08:40 AM Xamarin.Android 1
loading
Tags: SfDataGrid
stanicb
Asked On March 9, 2017 03:24 AM

Hi,
I have found a big problem considering sfDataGrid FrozenRowsCount and FrozenColumnsCount. When I set either of these properties, DataGrid drastically slows down, and when I say drastically, I mean that it takes about 2 seconds to react to touch and another 2 seconds to execute the attached method or command. So, am I doing something wrong here? All I have done is setting these properties.
Thanks in advance.

Vimal Prabhu Manohkaran [Syncfusion]
Replied On March 10, 2017 08:40 AM

Hi Stanic,

Thanks for contacting Syncfusion support.
 

We have checked your query by preparing a simple sample and setting FrozenColumnsCount and FrozenRowsCount as 3. However we were not able to reproduce the lag issue explained by you. We have checked the sample in Samsung Galaxy S6, Moto G4, Moto E, Google Pixel, Samsung Galaxy Tab A physical devices and KitKat emulator.

So we request you to share details such as,
 
1.     The layout you are loading the SfDataGrid. 
2.     The device you are testing 
3.     Whether you are loading template columns. 
4.     Performing any heavy weightage tasks in the OnDraw method if any template column used etc 
 
Hence it would be very helpful if you could provide a sample replicating the issue along with clear replication details. 

Regards,
Vimal Prabhu


CONFIRMATION

This post will be permanently deleted. Are you sure you want to continue?

Sorry, An error occured while processing your request. Please try again later.

You are using an outdated version of Internet Explorer that may not display all features of this and other websites. Upgrade to Internet Explorer 8 or newer for a better experience.

;