We use cookies to give you the best experience on our website. If you continue to browse, then you agree to our privacy policy and cookie policy.
Unfortunately, activation email could not send to your email. Please try again.
Syncfusion Feedback

Autocomplete Multi column using tag helpers is not working

Thread ID:

Created:

Updated:

Platform:

Replies:

128616 Feb 1,2017 12:08 PM UTC Feb 2,2017 09:29 AM UTC ASP.NET Core 1
loading
Tags: Autocomplete
Ramlith
Asked On February 1, 2017 12:08 PM UTC

Hi,
     Autocomplete multi column using taghelpers is not working i think there is an issues in e-multicolumnsettings string format i have enclosed my design coding 
please guide me to overcome this issues..

    <ej-autocomplete id="search2" filter-type="Contains" highlight-search="true" show-rounded-corner="true" enable-auto-fill="true"
     enable-distinct="true" show-popup-button="true" watermark-text="enter country name" items-count="20" min-character="2"
     width="150" popup-width="500px" popup-height="250px" show-reset-icon="true" visible="true">
        <e-multicolumnsettings show-header="true" enable="true" string-format="{0} ({1})">
            <e-columns field="CountryName" header-text="Country Name" />
            <e-columns field="CountryId" header-text="ID" />
            <e-columns field="FkSector" header-text="Sectors" />
            <e-columns field="LastUpdate" header-text="Updated On" />
        </e-multicolumnsettings>
        <e-datamanager adaptor="UrlAdaptor" url="/AgentMaster/SelectCountry" key="CountryId"></e-datamanager>
        <e-autocomplete-fields key="CountryId" text="CountryName" />
      </ej-autocomplete>

if i remove string-format and update like string-format="{0}" the event of this method are firing and getting field names are null
please help to overcome this issues..
need an sting format and how to populate  values..
I have attached my sample project please review

Thanks & Regards,
Rarmlith

Attachment: ebmsSyncFDemo_158b15c1.rar

Arun Palaniyandi [Syncfusion]
Replied On February 2, 2017 09:29 AM UTC

Hi Rarmlith,   
  
Thanks for contacting Syncfusion Support.   
  
We were also able to reproduce the mentioned issue. Instead of using the tag helper for Autocomplete MultiColumnSettings, you have to define the MultiColumnSettings object using the CSHTML Razor syntax and set it to multi-column-settings property. Right now, please use this workaround solution for using the multicolumn option in the Autocomplete.   
  
CSHTML:   
   
        @{ Syncfusion.JavaScript.Models.MultiColumnSettings setting = newSyncfusion.JavaScript.Models.MultiColumnSettings();   
            setting.Enable = true;   
            setting.StringFormat = "({0} {1})";   
            Syncfusion.JavaScript.Models.Columns cols = newSyncfusion.JavaScript.Models.Columns();   
            cols.Field = "CountryName";   
            cols.FilterType = FilterOperatorType.Contains; // use this filter type in columns   
            cols.Type = ColumnType.String;   
            cols.HeaderText = "Name";   
            Syncfusion.JavaScript.Models.Columns cols1 = newSyncfusion.JavaScript.Models.Columns();   
            cols1.Field = "CountryId";                // use this filter type in columns   
            cols1.FilterType = FilterOperatorType.Contains;   
            cols1.Type = ColumnType.String;   
            cols1.HeaderText = "ID";   
            List<Syncfusion.JavaScript.Models.Columns>   
                colslist = new List<Syncfusion.JavaScript.Models.Columns>   
                    ();   
            colslist.Add(cols1);   
            colslist.Add(cols);   
            setting.Columns = colslist;   
   
        }   
  
<ej-autocomplete id="search2" filter-type="Contains" highlight-search="true" show-rounded-corner="true" enable-auto-fill="true" datasource="(System.Collections.IEnumerable)ViewBag.datasource"enable-distinct="true" show-popup-button="true" watermark-text="enter country name" multi-column-settings="@setting"width="400" show-reset-icon="true" visible="true" >   
            <e-autocomplete-fields key="CountryId" text="CountryName" />   
        </ej-autocomplete>   
  
  
We have provided a simple sample below for your convenience. 
   
Please let us know if you have any further queries.   
   
  
Regards,   
Arun P.   


CONFIRMATION

This post will be permanently deleted. Are you sure you want to continue?

Sorry, An error occured while processing your request. Please try again later.

Warning Icon You are using an outdated version of Internet Explorer that may not display all features of this and other websites. Upgrade to Internet Explorer 8 or newer for a better experience.Close Icon

;