We use cookies to give you the best experience on our website. If you continue to browse, then you agree to our privacy policy and cookie policy.
Unfortunately, activation email could not send to your email. Please try again.
Syncfusion Feedback

Type 'Syncfusion.UI.Xaml.Grid.SfDataGrid' is not defined.

Thread ID:

Created:

Updated:

Platform:

Replies:

127878 Dec 15,2016 08:50 AM UTC Dec 19,2016 02:09 PM UTC WPF 3
loading
Tags: SfDataGrid
Ondrej Linhart
Asked On December 15, 2016 08:50 AM UTC

I created new WPF application (Visual Basic .NET), added SfDataGrid using Syncfusion Reference Manager and added very basic XAML:
<Window xmlns="http://schemas.microsoft.com/winfx/2006/xaml/presentation"
        xmlns:x="http://schemas.microsoft.com/winfx/2006/xaml"
        xmlns:d="http://schemas.microsoft.com/expression/blend/2008"
        xmlns:mc="http://schemas.openxmlformats.org/markup-compatibility/2006"
        xmlns:local="clr-namespace:Tests.Syncfusion"
        xmlns:syncfusion="http://schemas.syncfusion.com/wpf"
        x:Class="MainWindow"
        mc:Ignorable="d"
        Title="MainWindow" Height="350" Width="525">
  <Grid>
    <syncfusion:SfDataGrid HorizontalAlignment="Left" VerticalAlignment="Top" AllowFiltering="True" x:Name="SfDataGrid1"/>
  </Grid>
</Window>


When I try to run application, compiler error "Type 'Syncfusion.UI.Xaml.Grid.SfDataGrid' is not defined." occurs. I thought that Reference Manager will add everything that is needed. What should I reference to get it working?

Balamurugan Rajaraman [Syncfusion]
Replied On December 16, 2016 01:35 PM UTC

Hi Ondrej 
We have analyzed your query  Type 'Syncfusion.UI.Xaml.Grid.SfDataGrid' is not defined.”.In our side its working fine. Could you  reinstall your GAC assemblies and then create the new application by adding the reference manger. Let us know still you are facing the same trouble in your side. We have attached the tested sample for your reference. Please find the sample from the below link. 
 
Sample Link: 
  
 
Regards, 
Balamurugan. 



Ondrej Linhart
Replied On December 16, 2016 01:55 PM UTC

If I create new application, it works. But there is no way of getting that testing solution to work. I attached it to this message.

Attachment: Tests.Syncfusion_1678a82d.zip

Balamurugan Rajaraman [Syncfusion]
Replied On December 19, 2016 02:09 PM UTC

Hi Ondrej, 

 We have analyzed your query. You can remove the attached DLL in the project and then regain added it through the reference manger to clear the errors. We have modified your sample like that we attached the tested video for your reference. Please find the video from the below link. 

Video: 


Regards, 
Balamurugan. 


CONFIRMATION

This post will be permanently deleted. Are you sure you want to continue?

Sorry, An error occured while processing your request. Please try again later.

Warning Icon You are using an outdated version of Internet Explorer that may not display all features of this and other websites. Upgrade to Internet Explorer 8 or newer for a better experience.Close Icon

;