We use cookies to give you the best experience on our website. If you continue to browse, then you agree to our privacy policy and cookie policy.
Unfortunately, activation email could not send to your email. Please try again.
Syncfusion Feedback

Panning does not work when using shape files

Thread ID:

Created:

Updated:

Platform:

Replies:

127408 Nov 14,2016 04:37 PM UTC Nov 15,2016 12:46 PM UTC WPF 3
loading
Tags: Maps
pogosama
Asked On November 14, 2016 04:37 PM UTC

I tried to load some shape files downloaded from OpenStreetMap, with LayoutTile = Tile. But when I zoomed in to level 3, and tried to pan around, the panning behaved erratically. I can't pan to the right. I had to zoom out again and zoom in again. Sometimes the map just jumped around when I pan (on deeper zoom level).

I've attached the test project.

Second issue: The ShowCoords property shows the LatLong on the upper right corner, but it doesn't really update.

Attachment: TestProject_862664dc.zip

pogosama
Replied On November 15, 2016 07:28 AM UTC

Third issue: The SfMap.Pan(x, y) method also doesn't work correctly. I gave Latitude and Longitude numbers for x and y respectively, but it didn't pan to the correct position.

pogosama
Replied On November 15, 2016 09:01 AM UTC

Another issue I have: Why is zooming seems to be non-linear when I use ShapeFileLayer as source? On coarse zoom levels (1-5), i can zoom pretty quick, but on finer zoom levels (5+), it gets slower and slower to zoom to city/street level (I cannot really zoom in to street level).

This is not the case if I use OSM ImageryLayer. I see the world on zoom level 1. On zoom level 15 I'm already at street level.
When I use ShapeFileLayer (e.g. only the Isle of Man). I see the whole island on zoom level 1. On zoom level 80+ I'm still not that close to street level.

Mohana V [Syncfusion]
Replied On November 15, 2016 12:46 PM UTC

Hi Erik,

We have created a separate incident for further follow up's about “Panning does not work when using shape files” under your Direct-trac login account.

https://www.syncfusion.com/account/login?ReturnUrl=/support/directtrac/incidents

Regards,
Mohana V
 


CONFIRMATION

This post will be permanently deleted. Are you sure you want to continue?

Sorry, An error occured while processing your request. Please try again later.

Warning Icon You are using an outdated version of Internet Explorer that may not display all features of this and other websites. Upgrade to Internet Explorer 8 or newer for a better experience.Close Icon

;