We use cookies to give you the best experience on our website. If you continue to browse, then you agree to our privacy policy and cookie policy. (Last updated on: November 16, 2018).
Unfortunately, activation email could not send to your email. Please try again.
Syncfusion Feedback

DataGrid autoscroll on click

Thread ID:

Created:

Updated:

Platform:

Replies:

125739 Sep 8,2016 08:02 AM UTC Sep 9,2016 02:15 PM UTC WPF 1
loading
Tags: SfDataGrid
Martin Tichovsky
Asked On September 8, 2016 08:02 AM UTC

Hello,

i have problem with autoscrolling of datagrid when i click on random cell. For better idea, follow images bellow.

This is state 1, when i scroll page to table 2. Then i double click on the third row and second column, for example. And then datagrid automatically scroll, and my choise is gone. I think, that datagrid responds on focus, at first, and ignore mouse targeting. After scroll is everything ok, problem is with first choise, if datagrid isn't on top.



This is state 2, after clicking.



My question is: Is any option or anyting, for turn off autoscrolling of datagrid for this problem? Thank you very much


Attachment: Test_d0a9a6d5.zip

Jai Ganesh S [Syncfusion]
Replied On September 9, 2016 02:15 PM UTC

Hi Martin, 
 
You can achieve your requirement by wiring the RequestBringIntoView event for grid like below, 
 
this.grid.RequestBringIntoView += grid_RequestBringIntoView; 
this.grid1.RequestBringIntoView += grid1_RequestBringIntoView; 
 
void grid1_RequestBringIntoView(object sender, RequestBringIntoViewEventArgs e) 
{ 
    e.Handled = true; 
} 
 
void grid_RequestBringIntoView(object sender, RequestBringIntoViewEventArgs e) 
{ 
    e.Handled = true; 
} 
 
 
 
Regards, 
Jai Ganesh S 


CONFIRMATION

This post will be permanently deleted. Are you sure you want to continue?

Sorry, An error occured while processing your request. Please try again later.

Warning Icon You are using an outdated version of Internet Explorer that may not display all features of this and other websites. Upgrade to Internet Explorer 8 or newer for a better experience.Close Icon

;