We use cookies to give you the best experience on our website. If you continue to browse, then you agree to our privacy policy and cookie policy.
Unfortunately, activation email could not send to your email. Please try again.
Syncfusion Feedback

How to disable auto-scroll to focused/selected row?

Thread ID:

Created:

Updated:

Platform:

Replies:

125722 Sep 6,2016 05:30 PM UTC Sep 7,2016 01:06 PM UTC WPF 2
loading
Tags: GridDataControl
sgillbee
Asked On September 6, 2016 05:30 PM UTC

I have a GridDataControl with the following Xaml declaration:

        <sf:GridDataControl ItemsSource="{Binding Path=Constituents}"
                            UpdateMode="PropertyChanged"
                            NotifyPropertyChanges="True"
                            AutoPopulateColumns="False"
                            AutoPopulateRelations="False"
                            EnableVisualStyleForEditors="True"
                            EnableContextMenu="True"
                            ShowHoveringBackground="True"
                            ShowAddNewRow="False"
                            ShowFilters="False"
                            AllowEdit="True"
                            AllowDelete="False"
                            AllowGroup="True"
                            AllowSelection="Row"
                            AllowSort="True"
                            SelectFirstRowOnLoad="False"
                            ListBoxSelectionMode="MultiExtended">

The grid has about 700 items. One of the columns is an editable checkbox. All other columns are read-only. The problem is that once the user checks a checkbox, that row gets the focus and the grid attempts to keep that row visible. This is really bad since it makes it almost impossible to scroll to another row and change the checkbox on that row because the grid keeps scrolling the first row back into view. I cannot find a way to disable this auto scrolling focus behavior. I have tested this with AllowSelection="None" and ListBoxSelectMode="None" but even if no rows can be selected, the mere act of clicking the checkbox grants focus to the row and it gets scrolled to visible. Using the mouse wheel is impossible as, after a couple of scrolls the grid just resets back to the focused row.

Please advise.

sgillbee
Replied On September 6, 2016 05:36 PM UTC

...and, as often happens after a public forum post, I found the answer myself: setting AutoFocusCurrentItem property to "False" disables this behavior.

Jai Ganesh S [Syncfusion]
Replied On September 7, 2016 01:06 PM UTC

Hi Sgillbee 
 
We are glad that you have fixed your issue. 

Please let us know if you need any other assistance.
 
 
Regards, 
Jai Ganesh S 
 


CONFIRMATION

This post will be permanently deleted. Are you sure you want to continue?

Sorry, An error occured while processing your request. Please try again later.

Warning Icon You are using an outdated version of Internet Explorer that may not display all features of this and other websites. Upgrade to Internet Explorer 8 or newer for a better experience.Close Icon

;