We use cookies to give you the best experience on our website. If you continue to browse, then you agree to our privacy policy and cookie policy.
Unfortunately, activation email could not send to your email. Please try again.

Images and drop down boxes are not populating after configuring X-Content-Type-Options: nosniff response header

Thread ID:

Created:

Updated:

Platform:

Replies:

125633 Aug 30,2016 04:09 AM Sep 15,2016 12:54 AM ASP.NET Web Forms 5
loading
Tags: PivotClient
Sandeep
Asked On August 30, 2016 04:09 AM

Hi Team,

For the security purpose we have configured the web server to always send the X-Content-Type-Options: nosniff specification in the response headers. But images and drop down boxes are not populating after configuring this header. 

Please find the attached screenshots which would explain the issue clearly.

Could you please help us on how to fix this issue when X-Content-Type-Options: nosniff is configured?

Thank you,

Sandeep


Attachment: screenshots_cb3d031d.zip

Ramesh Govindaraj [Syncfusion]
Replied On August 31, 2016 07:02 AM

Hi Sandeep, 

Thank you for using Syncfusion products. 

The statement “X-Content-Type-Options: nosniff” in web.config file doesn’t consider MIME type info while deploying the sample which results some of the images/icons not displayed. This is happened only in Internet Explorer. Please find the following links which shows the conversation regarding the reported problem. 


So, kindly replace the above mentioned statement with any other alternative option to improve the security. 

Regards,
Ramesh G. 


Sandeep
Replied On August 31, 2016 11:50 AM

Hi Ramesh,

Thanks for your reply.

There is no alternatives for this security fix.

The issue is image type and the extension are not matching, so IE browser is not populating the images. Could you please review this from your end that why these images have mismatch?

Thank you, 
Sandeep 

Ramesh Govindaraj [Syncfusion]
Replied On September 1, 2016 04:09 AM

Hi Sandeep, 

We have raised your query in “Stack Overflow” and “MSDN” to get a solution for the reported problem. Please find the below links where you can trace the query to get the solution. 



Regards,
Ramesh G. 
 


Sandeep
Replied On September 14, 2016 06:29 AM

Hi Ramesh,

It's a known issue that when the image type and extension are not matching then IE browser will not populate that image. So please check why these images have mismatch.

An could you please follow up with the query in “Stack Overflow” and “MSDN” ?

Thanks,
Sandeep

Ramesh Govindaraj [Syncfusion]
Replied On September 15, 2016 12:54 AM

Hi Sandeep, 

We have added your query in both “Stack Overflow” and “MSDN”. Additionally we have raised the entire query in “ASP.NET” forum which was suggested from “MSDN”. Please find the below link to track “ASP.NET” forum. 
 

Regards,
Ramesh G. 
 


CONFIRMATION

This post will be permanently deleted. Are you sure you want to continue?

Sorry, An error occured while processing your request. Please try again later.

You are using an outdated version of Internet Explorer that may not display all features of this and other websites. Upgrade to Internet Explorer 8 or newer for a better experience.

;