We use cookies to give you the best experience on our website. If you continue to browse, then you agree to our privacy policy and cookie policy. Image for the cookie policy date

Issue editing boolean columns.


If you set a Grid control the locale property to "es-ES", when you edit a boolean column the checkbox editor is not shown.


1 Reply

BM Balaji Marimuthu Syncfusion Team March 11, 2016 08:59 AM UTC

Hi Jorge,

Thanks for contacting Syncfusion support.

We have enabled the “es-ES” locale to Grid and checked the reported issue. But we were unable to reproduce the issue from our side, the checkbox is showing properly when edit the records. Refer to the sample in following link.

Sample:  Sample-123362

If you still face issues, kindly share the following information that will be helpful to find the cause of issue and provide a better solution at the earliest.

1.     Essential Studio version and Browser version details.
2.     Edit Mode details.
3.     Are you using any adaptor in Grid or binding the local data?
4.     Scenario to reproduce the issue.
5.     Sample if possible or modify the attached sample as issue reproducible.
6.     Also, please ensure whether you have enabled the EditType property as Boolean to the check box column. Refer to the code example as below.

<ej:Column Field="Verified" HeaderText="Verified" EditType="Boolean" Width="80"></ej:Column>

Balaji Marimuthu

Live Chat Icon For mobile
Up arrow icon