We use cookies to give you the best experience on our website. If you continue to browse, then you agree to our privacy policy and cookie policy.
Unfortunately, activation email could not send to your email. Please try again.
Syncfusion Feedback

Controls do not render in Designer if ARM architecture

Thread ID:

Created:

Updated:

Platform:

Replies:

122067 Feb 13,2016 05:31 AM UTC Mar 24,2016 01:13 PM UTC UWP 5
loading
Tags: SfChart
Michael Sherburne
Asked On February 13, 2016 05:31 AM UTC

If ARM architecture is selected as target Syncfusion controls do not render in designer. As soon as I move the architecture to x85 or x64 controls render correctly. The same experience happens in Blend. I'm using Visual Studio 2015 Professional.

I have confirmed that once the control is deployed to an ARM based device the controls will render correctly. The device that I'm using is a Raspberry Pi with Windows IoT Core. That shouldn't matter in the designer though.

Rajkumar Ganesamoorthy [Syncfusion]
Replied On February 15, 2016 01:27 PM UTC

Hi Michael,

Thank you for contacting Syncfusion Support.

We have checked your reported issue. But we were unable to reproduce the reported issue from our side. We are able to render our control in designer when the target is in ARM. We attached the demo video which we checked from our side. Please find the video from the below attachment file.

Could you please provide more information about this issue? It will help us to analyze the problem and provide solution.

Regards,
Rajkumar G


Attachment: Demo2_93e748e3.zip

Gareth Day
Replied On March 13, 2016 11:33 AM UTC

I too have the same issue with Michael, how ever, I am wondering if this is possibly a Visual Studio issue.

When I target Arm (Windows Mobile Development) none of the syncfusion controls show in the designer but then neither do my own (a simple Image button control). Switch the Target to X86 and then they show.

Did stumble upon this post



Rajkumar Ganesamoorthy [Syncfusion]
Replied On March 14, 2016 09:08 AM UTC

Hi Gareth,

Thank you for your information.

We have analyzed your reported issue, in your update you mentioned that you were not able to add either our Syncfusion controls or your own custom control in designer with target mode as an ARM. But we were unable to reproduce the reported issue from our side. So could you provide more information like your system configuration and in which environment the reported issue occurs? This will help us to provide the solution for this issue.

Regards,
Rajkumar G

Simon Graf
Replied On March 23, 2016 09:37 AM UTC

Hi,
is your designer just not rendering your control or not responding? Dragging an sfchart to an empty page does not produce any visual here either (ARM | x86 | x64). But in case your designer in't responding or freezes for half a minute or so then your issue might be related to this one:  Designer locks in VS2015
Simon

Rachel A [Syncfusion]
Replied On March 24, 2016 01:13 PM UTC

Hi Michael,

Thanks for the update.

We are unable to reproduce the problem at our end. Could you please provide us the SDK version of the Syncfusion Controls which will be helpful for us to provide you a solution.

Regards,
Rachel.A

CONFIRMATION

This post will be permanently deleted. Are you sure you want to continue?

Sorry, An error occured while processing your request. Please try again later.

Warning Icon You are using an outdated version of Internet Explorer that may not display all features of this and other websites. Upgrade to Internet Explorer 8 or newer for a better experience.Close Icon

;