We use cookies to give you the best experience on our website. If you continue to browse, then you agree to our privacy policy and cookie policy. Image for the cookie policy date
close icon

Background image hidden by cells

I'm trying to display a background image that is displayed when there are no rows on the grid, but the image is hidden behind the rows and columns.

Currently the image shows through the cells with the BackgroundImage set, and TransparentBackground = true.

3 Replies

SA Solai A L Syncfusion Team February 1, 2016 08:57 AM UTC

Hi Roland,

Thank you for contacting Syncfusion Support.

Please refer to the following sample. In the below sample, we don’t use the transparent background property and the row and column count is set to 0. Still, the background image is applied to the grid properly. If the issue still exist, replicate the scenario in the following and update us.

Sample:
 http://www.syncfusion.com/downloads/support/forum/121838/ze/CS-154685599


Thanks ,
AL.Solai.



RB Roland Brooks February 1, 2016 03:32 PM UTC

The example was not correct, however it pointed me in the right direction. 
I found a solution that involves setting the background image of the control behind the grid (in this case the form), and then setting the following properties.

            gridControl1.SupportsTransparentBackColor = true;
            gridControl1.Properties.BackgroundColor = Color.Transparent;
            gridControl1.BackColor = Color.FromArgb(0, SystemColors.Window);

Now the cells are opaque, but the remainder of the control displays the background image.