We use cookies to give you the best experience on our website. If you continue to browse, then you agree to our privacy policy and cookie policy.
Unfortunately, activation email could not send to your email. Please try again.

HTMLUI Control will not load in Windows 10

Thread ID:

Created:

Updated:

Platform:

Replies:

121731 Oct 5,2015 02:03 PM Jan 22,2016 12:43 AM Windows Forms 6
loading
Tags: HTMLUIControl
Stephen L
Asked On October 5, 2015 02:03 PM

Anyone else seeing this issue? 
http://take.ms/kaCQ1

Kathiresan Subramaniam [Syncfusion]
Replied On October 6, 2015 08:54 AM

Hi Stephen,

We are unable check the reported issue with the information you have provided.

In order to check the reported issue, could you please share the steps briefly to reproduce issue in our end? If possible please share sample project and screenshots of the issue. The details which you sharing would be much helpful for us to check the issue and provide the solution at the earlier.

Regards,
Kathiresan S.

Serge Lalonde
Replied On January 19, 2016 02:14 PM

Hi Stephen,

We're getting the same problem on one of our PCs. Of course, it happens to be the PC of the support engineer whose responsible for the application in question.
All regression testing PCs (which are clean installs each time) and developer PCs, work perfectly.
Details that might be useful (confirm if you have the same environment):
  • The PC was upgraded from Windows 8.1 to Windows 10. It worked properly when it was Windows 8.1.
  • The application using the HTMLUI control targets the 64-bit platform.
  • I reinstalled .NET 2, 3.5 and 4.6.1. No change.
  • It doesn't fail to create the control, but nothing is ever rendered.
  • It fails for all user accounts on that PC (so it's not a user specific failure).
  • It works fin on other PCs that were upgraded to Windows 10 and on clean PC installs of Windows 10.

There must be an HTMLUI dependency missing, but I haven't found out yet what it is.

You posted this on 2015-10-05. Have you found a solution?


Thanks.


Saravanan T [Syncfusion]
Replied On January 20, 2016 01:11 PM

Hi Serge,

Thank you for your update.

We are unable to reproduce the reported behavior in our end. We found that the HTMLUI Control is loaded properly on the mentioned environment (Windows 10). Could you please look at the following attached video and let us know whether we have followed the correct reproducing steps?

http://www.syncfusion.com/downloads/support/forum/121731/ze/HTMLUI_Testing-1700140910

The following Syncfusion dependency assemblies are required for using HTMLUIControl.

·         Syncfusion.HTMLUI.Base.

·         Syncfusion.HTMLUI.Windows.

·         Syncfusion.Scripting.Base.

·         Syncfusion.Shared.Base.
If the required assemblies are added properly in your application, Could ensure the application target framework version is same as referred Syncfusion assemblies frame work version?

Additionally, could you check whether the Syncfusion Dashboard samples are working properly on your machine? The following KB article provides you the steps to access the samples, from Sample Browser WF.

KB Link: http://www.syncfusion.com/kb/5389/how-to-access-demo-samples-in-essential-studio-windows-form

Regards,
Saravanan T


Serge Lalonde
Replied On January 20, 2016 04:51 PM

Hi Saravanan,

I'm not surprised that you can't reproduce it. I'm having difficulty reproducing it on another PC myself.

However, I have made progress on the problematic PC and have determined that it's an issue with fonts that are installed by another application that are causing the problem.
If I remove the font registry entries on the problematic PC, the HTMLUI control behaves properly. If I put the font registry entries back in, it fails to render. No exceptions are ever generated in the Syncfusion code. See below.

Additionally, if I remove the fonts while the HTMLUI application is running (BTW, I reproduced the bug with the HTMLUI_Explorer sample), new HTMLUI controls that get created still don't work. It only starts working again once the application is closed and started again. This tells me that there must be some kind of static data (some kind of font cache perhaps?) that loads at startup and doesn't get refreshed.

The fonts that cause the problem are the first ones in the list of fonts found in HKEY_LOCAL_MACHINE\SOFTWARE\Microsoft\Windows NT\CurrentVersion\Fonts:


In fact, just deleting the registry values for "3ds (TrueType)", "3ds-Bold (TrueType)", "3ds-BoldItalic (TrueType)", and "3ds-Italic (TrueType)" makes the HTMLUI control work again.
The only odd thing about those fonts is that the extension for the font file is .ttf, (for TrueType) but the fonts are in fact OpenType fonts, which is reported by Windows if you double-click the font file manually to view it. I doubt that this is the problem, but it's weird that these are the only ones that cause the problem and that they're the only ones with the incorrect extension.

Is there any Syncfusion code that loads fonts and could fail for some reason? Maybe the static "font manager" isn't loading any fonts at all because the first one fails. If so, it should continue trying to load the rest of the fonts and ignore the failure of loading a single font.

I tried with older versions of our application that used previous versions of Syncfusion and the problem existed then also. So the problematic code has been around for a while.
We're currently using Essential Studio 13.2.0.34.

Thanks.

Serge Lalonde
Replied On January 21, 2016 10:53 AM

Hello Saravanan,

Also to note. I'm using Visual Studio 2010 SP1, the  .NET 4 framework and Syncfusion assembly versions 13.2400.0.34.
This is different from your video.

Senthil Kumaran Rajan [Syncfusion]
Replied On January 22, 2016 12:43 AM

Hi Serge,

We have created the a support incident under your account, to track the status of this requirement. Please log on to our support website to check for further updates.

https://www.syncfusion.com/account/login?ReturnUrl=/support/directtrac/incidents

Regards,
Senthil

CONFIRMATION

This post will be permanently deleted. Are you sure you want to continue?

Sorry, An error occured while processing your request. Please try again later.

You are using an outdated version of Internet Explorer that may not display all features of this and other websites. Upgrade to Internet Explorer 8 or newer for a better experience.

;