We use cookies to give you the best experience on our website. If you continue to browse, then you agree to our privacy policy and cookie policy.
Unfortunately, activation email could not send to your email. Please try again.

COMException

Thread ID:

Created:

Updated:

Platform:

Replies:

120284 Sep 17,2015 06:48 AM Oct 5,2015 08:54 AM UWP 7
loading
Tags: SfTreeNavigator
Geoff Cornwell
Asked On September 17, 2015 06:48 AM

Hi,
I'm using the SfTreeNavigator in a Windows 10 Universal app. The app starts up fine but it frequently throws an unhandled COM exception when an item is clicked. The crash appears random as sometimes an item will click OK and sometimes not. Here is the error stack.
System.Runtime.InteropServices.COMException: Error HRESULT E_FAIL has been returned from a call to a COM component.
at Windows.UI.Xaml.Controls.ItemsControl.get_ItemTemplate()
at Syncfusion.UI.Xaml.Controls.Navigation.SfTreeNavigator.NavigateItem(SfTreeNavigatorItem treeitem)
at Syncfusion.UI.Xaml.Controls.Navigation.SfTreeNavigator.Select(Object item)
at Syncfusion.UI.Xaml.Controls.Navigation.SfTreeNavigator.OnSelectionChanged(DependencyPropertyChangedEventArgs args)
at Syncfusion.UI.Xa
Any Ideas?
Thanks,
Geoff

Sugapriya Mariappan [Syncfusion]
Replied On September 18, 2015 03:24 AM

Hi Geoff,

Sorry for the inconvenience caused

We have prepared a sample based on your update but we are unable to reproduce reported issue at our end.

Kindly download the sample and video from the below link

Sample link:SfTreeNavigatorSample(1)

Video link:Video

Can you please check the updated sample and video and provide more information about the reported issue? It would be helpful for us to provide you the better solution at the earliest.

Please let us know if you have any other concern,

Regards,
M.Sugapriya

Geoff Cornwell
Replied On September 18, 2015 06:36 AM

Hi,

I've had a look at the attached solution. It looks like I need an updated dll. My solution is using 13.2.0.34 whereas the example is version 13.3.0.5. Could you tell me where I can find the updated dll?

Thanks,

Geoff

Sugapriya Mariappan [Syncfusion]
Replied On September 21, 2015 01:44 AM

Hi Geoff,

Sorry for the inconvenience caused

We have checked our last updated sample with the version 13.2.0.34. But we are still unable to reproduce the reported issue at our end.

Please find the sample from the following link:
Sample link:SfTreeNavigatorSample

Could you please check our sample and provide more information about the reported issue? So that it would be helpful for us to proceed further on this.

Please let us know if you have any other concern

Regards,
M.Sugapriya

Geoff Cornwell
Replied On September 22, 2015 05:23 AM

Hi,

Thanks for the response. I have been able to get your sample to work but I am still having problems with my code. The two major differences I can see between the implementations are the way that I am creating the data template and my view model. I am creating a hierarchical model that is deeper than the two levels in your model. Please see my attached solution for details. Is it possible to display data modelled this way or do I need to define a fixed depth?

Many thanks,

Geoff

Attachment: SfTreeSample_ebbc38e5.zip

Mariappan S [Syncfusion]
Replied On September 24, 2015 12:42 AM

Hi Geoff,

We were able to reproduce the issue and have logged defect report regarding this. A support incident to track the status of this defect has been created under your account. Please log on to our support website to check for further updates

https://www.syncfusion.com/account/login?ReturnUrl=%2fsupport%2fdirecttrac%2fincidents

Please let me know if you have any questions.

Regards,
Mariappan S

Stergios
Replied On October 2, 2015 11:57 AM

I've got exactly the same problem and I can see the same error stack.

Can you please provide any additional information regarding the solution to this problem?

I'm also using the HierarchicalDataTemplate.

Thanks 

Sugapriya Mariappan [Syncfusion]
Replied On October 5, 2015 08:54 AM

Hi Stergios,

Thank you for contacting Syncfusion support

We have already logged a defect report regarding the reported issue and we will include this fix in our upcoming service pack Volume 3 SP1 release which will be available at the end of October 2015.

Please let us know if you need any other assistance

Regards,
M.Sugapriya

CONFIRMATION

This post will be permanently deleted. Are you sure you want to continue?

Sorry, An error occured while processing your request. Please try again later.

You are using an outdated version of Internet Explorer that may not display all features of this and other websites. Upgrade to Internet Explorer 8 or newer for a better experience.

;