We use cookies to give you the best experience on our website. If you continue to browse, then you agree to our privacy policy and cookie policy. (Last updated on: November 16, 2018).
Unfortunately, activation email could not send to your email. Please try again.
Syncfusion Feedback

Prevent "flicker" when enabling tabs.

Thread ID:

Created:

Updated:

Platform:

Replies:

119663 Jul 20,2015 03:11 PM UTC Jul 22,2015 04:54 AM UTC JavaScript 3
loading
Tags: ejTab
Robert David
Asked On July 20, 2015 03:11 PM UTC

Hello. I'm trying to prevent the tab control from flickering when I update the disabled tabs to be enabled.
On your demo page http://mvc.syncfusion.com/demos/web/tab/methods  in the API section if you disable a tab then enable it the tabs will flicker.
Is it possible to make it not flicker?


Harikrishnan P [Syncfusion]
Replied On July 21, 2015 02:50 PM UTC

Hi Robert,

Thanks for using Syncfusion products.

The Animation effect provided to the Tab looks like “flickering” when you enable and disable it. If needed we can stop this by disabling the ‘enableAnimation’ property as shown below


$("#apiTab").ejTab({enableAnimation:false});


We have showcased this in the following JS playground link please check it.

http://jsplayground.syncfusion.com/a40noy3a

Please let us know if you have further queries.

Regards,
HariKrishnan

Robert David
Replied On July 21, 2015 03:03 PM UTC

That's worked brilliantly thank you.

Harikrishnan P [Syncfusion]
Replied On July 22, 2015 04:54 AM UTC

Hi Robert,
 
Thanks for your update. Please get back to us if you would require further assitance, we will be happy to help you.
 
Regards,
HariKrishnan

CONFIRMATION

This post will be permanently deleted. Are you sure you want to continue?

Sorry, An error occured while processing your request. Please try again later.

Warning Icon You are using an outdated version of Internet Explorer that may not display all features of this and other websites. Upgrade to Internet Explorer 8 or newer for a better experience.Close Icon

;