We use cookies to give you the best experience on our website. If you continue to browse, then you agree to our privacy policy and cookie policy. (Last updated on : Nov 16th 2018).
Unfortunately, activation email could not send to your email. Please try again.
Syncfusion Feedback

Option Enabled(false) doesn't work very well.

Thread ID:

Created:

Updated:

Platform:

Replies:

119528 Jul 3,2015 07:29 PM UTC Jul 8,2015 04:42 AM UTC ASP.NET MVC 3
loading
Tags: Button
Julio
Asked On July 3, 2015 07:29 PM UTC

Hello, i have a problem with the propriety "Enabled(false)" of the button ; the button color changes (as disabled) but you still can click it and make the submit. 

Also i would like to know how use this propriety "HtmlAttributes"; if i can change the style or something.

Thanks and Regards

 

Kasithangam C [Syncfusion]
Replied On July 6, 2015 09:30 AM UTC

Hi Julio,

Thanks for using Syncfusion Products,

Query 1: i have a problem with the propriety "Enabled(false)" of the button ; the button color changes (as disabled) but you still can click it and make the submit.

We have analyzed query. We are unable to reproduce the issue “Enabled(false) property is not working” in the version 13.1.0.30. When we set enabled property as false, its move into disable state and it doesn’t make submit. We have prepared the sample based on this and please find the sample under the following location,

Sample: Sample

Could you please check the above sample? If still you face the problem, please revert us by modifying the sample based on your application along with replication procedure. Also, Can you please tell us which version of our product currently you are using?  This would be helpful for us to serve you.

Query 2: I would like to know how use this propriety "HtmlAttributes"; if i can change the style or something.

We can apply style for the button by using “HtmlAttributes” property. Please find the below code for using HtmlAttributes,

<code>

@Html.EJ().Button("button1").Text("Click").HtmlAttributes(new Dictionary<string, object> { { "style", "color:red" }, { "autocomplete", "off" } })

</code>

We have included this in the above attached sample. Please let us know if you have further queries.

Regards,

Kasithangam


Julio
Replied On July 7, 2015 05:49 PM UTC

Kasithangam thanks for the answers; the Queries function perfect, i will check where is the bug in my project.

Regard

Kasithangam C [Syncfusion]
Replied On July 8, 2015 04:42 AM UTC

Hi Julio,

Thanks for your update. Please get back to us if you have further queries. We will be happy to help you out.

Regards,
Kasithangam

CONFIRMATION

This post will be permanently deleted. Are you sure you want to continue?

Sorry, An error occured while processing your request. Please try again later.

Warning Icon You are using an outdated version of Internet Explorer that may not display all features of this and other websites. Upgrade to Internet Explorer 8 or newer for a better experience.Close Icon

;