We use cookies to give you the best experience on our website. If you continue to browse, then you agree to our privacy policy and cookie policy. Image for the cookie policy date

Why can''t I get a RightToLeft grid to work?

I''m evaluating essential suite for my Hebrew app. I''ve attached a sample in which I''ve tried to make a grid RTL, but to no avail. any tips? SyncFusionRTLGrid_5010.zip

7 Replies

AD Administrator Syncfusion Team March 17, 2004 05:42 AM

RTL is not currently supported in our grids. It is one of the the things we plan to add after the 2.0 release.


AD Administrator Syncfusion Team March 17, 2004 06:18 AM

on 10/8/2003, Stefan Hoenig claimed this should be ready in "a couple of months". (http://www.syncfusion.com/support/forums/message.aspx?MessageID=2699) that was 7 months ago. Is there a better time estimate on this now?


AD Administrator Syncfusion Team March 17, 2004 11:38 AM

I do not have an estimate for this work. Our 2.0 release has and is taking much longer than we intended.


AD Administrator Syncfusion Team August 24, 2004 11:49 PM

Hi, I downloaded the new evaluation and the RTL grid works - mazal tov :-) But even though the column style has a RightToLeft property, I can''t get it to affect the grid. I want most of the columns to be RTL but the numeric columns should be LTR, otherwise negative numbers appear with the minus sign on the right, which is wrong.


AD Administrator Syncfusion Team August 25, 2004 01:26 AM

If you have set the style.CellValueType, I think you can get the minus sign to appear on the left by explicitly setting the style.Format property (to put it on the right which gets reversed when it is displayed RTL). So, this setting seemed to work for me. this.gridDataBoundGrid1.Binder.InternalColumns[1].StyleInfo.Format = "#0.00;#0.00-";


DP Dror Pumerants August 26, 2004 03:14 AM

Though the Format property seems to solve the display of the minus, the data is always right aligned regardless of the TextAlign value. (I used gridGroupingControl1.TableDescriptor.Columns["myColumn"].Appearance.AnyRecordFieldCell.Format) It is a bug ? >If you have set the style.CellValueType, I think you can get the minus sign to appear on the left by explicitly setting the style.Format property (to put it on the right which gets reversed when it is displayed RTL). So, this setting seemed to work for me. > >this.gridDataBoundGrid1.Binder.InternalColumns[1].StyleInfo.Format = "#0.00;#0.00-"; >


AD Administrator Syncfusion Team August 26, 2004 03:31 AM

TextAlign controls the placement of text with respect to any buttons present in the cell. To control horizontal alignment, try the HorizontalAlignment property instead.

Loader.
Live Chat Icon For mobile
Up arrow icon