We use cookies to give you the best experience on our website. If you continue to browse, then you agree to our privacy policy and cookie policy.
Unfortunately, activation email could not send to your email. Please try again.

Double clicking on node or connector goes to edit mode

Thread ID:

Created:

Updated:

Platform:

Replies:

117020 Jul 21,2014 03:47 PM Jul 23,2014 08:19 AM ASP.NET Web Forms 4
loading
Tags: Diagram
Anjanaa Parasuraman
Asked On July 21, 2014 03:47 PM

Hello 
In the link below
http://asp.syncfusion.com/demos/ui/diagram/Layout%20Algorithm/Hierarchical%20Layout/CS/HierarchicalLayout.aspx
If I double click on any node or a connector, I see a feature to edit the label within. Goes to an edit mode. 
How can I disable it? 

Thanks
Anjanaa

Ashok Kumar V [Syncfusion]
Replied On July 22, 2014 01:21 AM

Hi Anjanna,

 

Thanks for your interest in Syncfusion product.

 

We suggest you to set DiagramwebControl’s “InPlaceEditing” property to false to disable the

 

Node’s Label editor. Please refer the below code snippet and the attached sample for your

 

reference.

 

 

Here is the code:

 

[C#]

 

//To Disable the Label Editor

 

DiagramWebControl1.InPlaceEditing = false;

 

 

Please try the above sample and let us know if any queries.

 

 

Regards,

 

Ashok Kumar.


Attachment: 117020_55e0de87.zip

Anjanaa Parasuraman
Replied On July 22, 2014 11:36 AM

Thanks for your help Asha. InPlaceEditing works. 

Thanks
Anjanaa

Anjanaa Parasuraman
Replied On July 22, 2014 11:37 AM

oops! typo mistake. I meant Ashok. I typed it by mistake as Asha. 

Ashok Kumar V [Syncfusion]
Replied On July 23, 2014 08:19 AM

Hi Anjanna,

Thanks for your reply.

We are happy that the problem is resolved. 

Thanks,
Ashok Kumar.

CONFIRMATION

This post will be permanently deleted. Are you sure you want to continue?

Sorry, An error occured while processing your request. Please try again later.

You are using an outdated version of Internet Explorer that may not display all features of this and other websites. Upgrade to Internet Explorer 8 or newer for a better experience.

;