We use cookies to give you the best experience on our website. If you continue to browse, then you agree to our privacy policy and cookie policy.
Unfortunately, activation email could not send to your email. Please try again.

Not able to Scroll vertically

Thread ID:

Created:

Updated:

Platform:

Replies:

116147 Apr 12,2014 11:44 PM Apr 14,2014 12:05 PM WinRT 1
loading
Tags: SfDataGrid
Rajakumar
Asked On April 12, 2014 11:44 PM

I'm using sync fusion data grid in my project.

The scenario is : I'm using few syncfusion datagrid inside my listview.  When I scroll vertically focusing on the datagrid, not able to scroll.  But when I focus out of the datagrid, I'm able to scroll vertically.  What happens here is the ListView is the parent & have few datagrid as child.  So the child is placed at the top of the listview & the focus is set to the datagrid rather ListView.  I want to scroll even when I focus on the datagrid.

Below is the way how I place the controls in my project.
1. Listview
    1.1 StackPanel
        1.1.1 SyncFusion Datagrid
        1.1.2 SyncFusion Datagrid
        1.1.3 SyncFusion Datagrid

Please let me know should you require any other information to solve this issue.  Any help is very much appreciated.

Thanks,
Rajakumar.S

Pradeepa R V [Syncfusion]
Replied On April 14, 2014 12:05 PM

Hi RajaKumar

 

Thank you for contacting Syncfusion support.

 

We analyzed your query. If you place SfDataGrid inside the Listview or Stack panel, it will lose the virtualization, all the rows will be rendered directly, and grid scrolling will be disabled. If you want to enable the virtualization you need to set the width and height to the SfDataGrid instance.

 

Please let us know if you have any questions.

 

Regards

Pradeepa


CONFIRMATION

This post will be permanently deleted. Are you sure you want to continue?

Sorry, An error occured while processing your request. Please try again later.

You are using an outdated version of Internet Explorer that may not display all features of this and other websites. Upgrade to Internet Explorer 8 or newer for a better experience.

;