We use cookies to give you the best experience on our website. If you continue to browse, then you agree to our privacy policy and cookie policy. Image for the cookie policy date

MaskEdit question

I have a virtual grid that has the ActivateCurrentCellBehavior set to DblClickOnCell. However, when I make some of the cell to a MaskEdit CellType in the QueryCellInfo(..), than whenever I single click on the grid, the cell automatic turn into edit mode. Can any one suggest a way to prevent the cell goes into edit mode?

3 Replies

AD Administrator Syncfusion Team March 10, 2004 02:53 PM

This behavior has been changed in the 2.0 code base so this shoul dnot be a problem in 2.0. In 1.6.1.8, if you don''t want to see the MaskEdit active, you can handle the CurrentCellStartEditing event and cancel it. But this would never let it be active. If you want to be able to activate it on a DoubleClick, then you would have to set some flag to allow this. Here are some code snippets.
bool okToStartEditing = false;
private void gridControl1_CurrentCellStartEditing(object sender, ComponentModel.CancelEventArgs e)
{
	if(!okToStartEditing)
		e.Cancel = true;
	okToStartEditing = false;
}

private void gridControl1_DoubleClick(object sender, System.EventArgs e)
{
	okToStartEditing = true;
	this.gridControl1.CurrentCell.BeginEdit();
}


PA Patrick March 11, 2004 11:07 AM

I am using 2.0.2.1 beta version and I see the current cell goes into edit mode if I use the arrow key to navigate to a cell.


AD Administrator Syncfusion Team March 11, 2004 11:44 AM

This fix was made after 2.0.2.1. In the code I am running, the maskedit cell does not active on a click if you have the activation set to doubleclick.

Loader.
Live Chat Icon For mobile
Up arrow icon