We use cookies to give you the best experience on our website. If you continue to browse, then you agree to our privacy policy and cookie policy.
Unfortunately, activation email could not send to your email. Please try again.
Syncfusion Feedback

Export to excel generates extra lines

Thread ID:

Created:

Updated:

Platform:

Replies:

115846 Feb 11,2014 02:49 AM UTC Feb 21,2014 09:13 AM UTC ASP.NET Web Forms (Classic) 4
loading
Tags: GridGroupingControl
Jo Scothern
Asked On February 11, 2014 02:49 AM UTC

We are using the GridGroupingControl to export a dataset into an excel file. This is working ok, except that the generated file has 3 extra rows at the top of the file - 2 blank lines a a line that says "Table: n Items".

Is there an easy way to make it so these extra lines are not generate with the export?

Example code:
var syncGrid = new GridGroupingControl
{
    DataSource = data.Tables[0]
};
excel.ExportNestedTable = true; excel.Export();

Any help with this would be greatly appreciated.

Thanks
Jo

Eswari S [Syncfusion]
Replied On February 17, 2014 04:24 AM UTC

Hi Jo,

 

Thank you for using Syncfusion products.

 

We were unable to reproduce the issue. We have prepared vide demonstrating of the sample and the same can be downloaded from the following link:

 

http://www.syncfusion.com/downloads/support/directtrac/118803/115846-1751086072.zip

 

http://www.syncfusion.com/downloads/support/directtrac/118803/Video-807282540.zip

 

Could you please try with the sample and if still issue reproduces please provide us some more information regarding the issue or else please modify the sample to reproduce the issue so that we can analyze based on that and provide you better solution.

 

Please try this and let us know if you have any queries.

 

Regards,

Eswari S


Jo Scothern
Replied On February 17, 2014 08:09 PM UTC

Thanks Eswari,

We were using an older version, so I guess I will simply need to update to get rid of two of the blank lines.

Is it possible to get rid of the line that mentions the number of items in the table, in your example it says:

"Table1: 13 Items ( Showing 1 to 12 )"

Thanks
Jo

Eswari S [Syncfusion]
Replied On February 19, 2014 10:37 AM UTC

Hi Jo,

 

Thanks for your update.

 

The reported issue “ Setting Caption Row (Table1: 13 Items ( Showing 1 to 12 ))  as false , gives blank row while exporting ” is suspected to be defect and we will update you with further validation details on 02/21/2014.

 

Also could you please share the Essential Studio current version which you are using and screenshot of the exported sheet which contains two blank lines or sample files of the grid ? Since we can able to reproduce one blank row issue by setting caption row as false , not two blank rows as you have specified. The information provided would be of great help in resolving the issue.

 

Let us know if you have any queries.

 

Regards,

Eswari S


Eswari S [Syncfusion]
Replied On February 21, 2014 09:13 AM UTC

 

Hi Jo,

 

Thanks for your patience.

 

We are able to reproduce the issue “Removing Blankrow with Showcaption(false)”, in order for you to get a solution for this behaviour, please contact us at Syncfusion Support or you may also open a support ticket by login in to direct trac account and mention this forum link for reference.

 

Please let us know if you need any further assistance.

 

Regards,

Eswari S

 


CONFIRMATION

This post will be permanently deleted. Are you sure you want to continue?

Sorry, An error occured while processing your request. Please try again later.

Warning Icon You are using an outdated version of Internet Explorer that may not display all features of this and other websites. Upgrade to Internet Explorer 8 or newer for a better experience.Close Icon

;