We use cookies to give you the best experience on our website. If you continue to browse, then you agree to our privacy policy and cookie policy. (Last updated on: November 16, 2018).
Unfortunately, activation email could not send to your email. Please try again.
Syncfusion Feedback

Visual Style dont work

Thread ID:

Created:

Updated:

Platform:

Replies:

115617 Jan 27,2014 12:19 AM UTC Feb 1,2014 12:26 PM UTC WinForms 4
loading
Tags: ScheduleControl
Sergiy Tokarchuk
Asked On January 27, 2014 12:19 AM UTC

I use SheduleControl and in Designer choose Appereance.VisualStyle=Metro or any other it just didnt change anything =((


Karuppasamy C [Syncfusion]
Replied On January 27, 2014 02:22 PM UTC

Hi Sergiy,

Thank you for using Syncfusion Products.

As you mentioned,I  have tried to change the visual style in designer mode of Schedule Control at my end. I am able to reproduced the issue at my end. I have suspected this to be a bug and ready to give you patch . The patch is only provided to licensed clients through Direct - Trac system only which is more reliable one. So I request you to open new incident in Direct - Trac  in order to get patch.

Suggestion #1:

But the visusal styles  are worked in schedule control  (running mode)by setting options in the view  tab of schedule control. You can change the styles as you want  by using this.

Screen Shots :

Regarding suggestion #1, I have shown the screen shots below

Screen Shot 1:


Screen Shot 2:



Suggestion #2:

You can change the visual styles of the Schedule control through programmatically by using the below  code snippet. Please refer the below code,

Code :

scheduleControl1.Appearance.VisualStyle = Syncfusion.Windows.Forms.GridVisualStyles.Metro;

Please let me know if you need any clarifications.

Regards,
Karuppasamy C.

Sergiy Tokarchuk
Replied On January 27, 2014 04:08 PM UTC

But it dosnt :( 
 public partial class test : Form
    {
        public test()
        {
            InitializeComponent();
            this.scheduleControl1.Appearance.VisualStyle = Syncfusion.Windows.Forms.GridVisualStyles.Metro;
        }
    }
And after i run the program the visual Styles dont change. Whe i run the samples i can change Visual Styles on runtime in a sample example . 
Im using 11.4.0.26 on Windows 8 in VS 2012.
Just check the ZIP file what i attachet it contains source code with example.  


testShedule_31920807.zip

Sergiy Tokarchuk
Replied On January 28, 2014 12:27 PM UTC

So i found the solution 
The bug was in 
this.scheduleControl1.ScheduleType = ScheduleViewType.Month;
if u set the Visual Style without setting SheduleType nothing will changes
As experiment i open ur ScheduleSample and comment this code

//this.scheduleControl1.ScheduleType = ScheduleViewType.Month; - after it no Visual Styles !!!

Working code :
       InitializeComponent();
            this.scheduleControl1.ScheduleType = Syncfusion.Windows.Forms.Schedule.ScheduleViewType.Month;
            this.scheduleControl1.Appearance.VisualStyle = Syncfusion.Windows.Forms.GridVisualStyles.Metro;

Not Working Code 
       InitializeComponent();
            this.scheduleControl1.ScheduleType = //Syncfusion.Windows.Forms.Schedule.ScheduleViewType.Month;
  //          this.scheduleControl1.Appearance.VisualStyle = Syncfusion.Windows.Forms.GridVisualStyles.Metro;

Fix this !!!! 

Karuppasamy C [Syncfusion]
Replied On February 1, 2014 12:26 PM UTC

Hi Sergiy,

Thank you for your update.

According to our previous update,You have created the new incident in order to get the patch.We appreciate your  cooperation  and let you know with proper fix through incident. Please have the follow-up from it.

Thanks & Regards,
Karuppasamy C.

CONFIRMATION

This post will be permanently deleted. Are you sure you want to continue?

Sorry, An error occured while processing your request. Please try again later.

Warning Icon You are using an outdated version of Internet Explorer that may not display all features of this and other websites. Upgrade to Internet Explorer 8 or newer for a better experience.Close Icon

;