We use cookies to give you the best experience on our website. If you continue to browse, then you agree to our privacy policy and cookie policy.
Unfortunately, activation email could not send to your email. Please try again.

Client side model not clear

Thread ID:

Created:

Updated:

Platform:

Replies:

114056 Oct 25,2013 04:49 AM Nov 7,2013 11:45 PM ASP.NET Web Forms (Classic) 3
loading
Tags: GridGroupingControl
Mustafa Hacibekir
Asked On October 25, 2013 04:49 AM

I have not found any reference of the client side model for the grouping grid. I also tried the example from Show/Hide Columns section:

========================================

Client-Side Show / Hide Column
On the client-side, columns can be shown or hidden using the following APIs.

• ShowColumn(columnindex)
• HideColumn(columnindex)

Please refer the below code snippet which illustrates this.

[JScript]

var gridTable = GetEGridTable( $get('<%= GridGroupingControl1.ClientID %>') );
gridTable.HideColumn( val );
gridTable.ShowColumn( val );
========================================

I see that my gridTable is "undefined" while the div is in place and has the right name.
I could not find the library used for GetEGridTable function.
You can find sample project and screen shot attached.
Thank you.


ClientsideColumnHideShow_a6eed60e.rar

Sandhya D [Syncfusion]
Replied On October 29, 2013 09:12 AM

Hi Mustafa,

Thank you for your interest in syncfusion products.

Your query "Client side model not clear"  can be achieved by setting datasource to the grid.

Please refer the code below.

[Default.aspx.cs]:

protected void Page_Load(object sender, EventArgs e)
{
if (!IsPostBack)
{
List<MyClass> list = new List<MyClass>();
//Empty records;
this.GridGroupingControl1.DataSource = list;
}
}

We have attached sample for your reference . Please get back to us if you need further assistance.

Regards
Sandhya D


   



ClientsideColumnHideShow_a6eed60e_(1)_22037823.zip

Mustafa Hacibekir
Replied On November 7, 2013 08:43 AM

It's working now. Thanks for the clue. 


Eswari S [Syncfusion]
Replied On November 7, 2013 11:45 PM

Hi Mustafa,

 

Thanks for your update.

 

We are happy to hear that you issue has been resolved.

 

Please let us know if you have any queries.

 

Regards,

Eswari S


CONFIRMATION

This post will be permanently deleted. Are you sure you want to continue?

Sorry, An error occured while processing your request. Please try again later.

You are using an outdated version of Internet Explorer that may not display all features of this and other websites. Upgrade to Internet Explorer 8 or newer for a better experience.

;