We use cookies to give you the best experience on our website. If you continue to browse, then you agree to our privacy policy and cookie policy. (Last updated on : Nov 16th 2018).
Unfortunately, activation email could not send to your email. Please try again.
Syncfusion Feedback

XPMenu state is not persisted in my application.

Thread ID:

Created:

Updated:

Platform:

Replies:

11274 Mar 1,2004 07:00 PM UTC Mar 2,2004 07:33 PM UTC WinForms 3
loading
Tags: Tools
Administrator [Syncfusion]
Asked On March 1, 2004 07:00 PM UTC

Hi, I am using XP Menu frame work(1.6.1.8 VS.NET 2003) in my application. I have some predefined menus added through designer. I am adding a few bar items dynamically through code based on application privileges. If I turn on/off some toolbars using the context menu on toolbar area, and quit my application, comeback as same user, the toolbar customizations are gone? I tried this with a simple example, it seems to work. There is something going on in my application (created using 1.5.x tools). Is there something I am doing wrong? Is there something I can look at or some how debug it and fix it??? Any ideas ... cheers, - Reddy

Administrator [Syncfusion]
Replied On March 1, 2004 11:58 PM UTC

Hi Reddy, 1. Essential Suite v1.5 is very old (belongs to the pre VS.NET 2003 times), and we do not support that anymore. Please upgrade all your applications to atleast v1.6.1.8 level. 2. Also, I am afraid, we will not able to help you much without a sample to consistently reproduce the problem that you are facing. Could you please create a sample that closely resembles your application and see if you can recreate the above mentioned error? Kindly try this and let us know how it goes. I understand that you have already tried this before, but it is nearly impossible for us to indicate what could possibly go wrong without a sample. We appreciate your cooperation on this issue. Regards, Guru Patwal Syncfusion, Inc.

Administrator [Syncfusion]
Replied On March 2, 2004 02:41 PM UTC

Guru, I am running 1.6.1.8 version. But the gui layout was done using 1.5.x. Is there something I need todo with my .resx files ? thanks, - Reddy

Administrator [Syncfusion]
Replied On March 2, 2004 07:33 PM UTC

Hi Reddy, 1. Modify your application slightly in the designer (maybe resize your main form a bit) so that the resources get regenerated. 2. Delete the Syncfusion policy files in the GAC 3. In the Solution Explorer window, delete all the Syncfusion dlls and re-add the v1.6.1.8 dlls. Now rebuild your application against v1.6.1.8, and run the application. Please try this and let me know how it goes. Thanks for your cooperation. Regards, Guru Patwal Syncfusion, Inc.

CONFIRMATION

This post will be permanently deleted. Are you sure you want to continue?

Sorry, An error occured while processing your request. Please try again later.

Warning Icon You are using an outdated version of Internet Explorer that may not display all features of this and other websites. Upgrade to Internet Explorer 8 or newer for a better experience.Close Icon

;