We use cookies to give you the best experience on our website. If you continue to browse, then you agree to our privacy policy and cookie policy.
Unfortunately, activation email could not send to your email. Please try again.

DataBoundGrid EnableEdit = false

Thread ID:

Created:

Updated:

Platform:

Replies:

10995 Feb 19,2004 04:26 AM Feb 23,2004 03:05 AM Windows Forms 3
loading
Tags: GridControl
Richard Deverson
Asked On February 19, 2004 04:26 AM

What is the expected behaviour when I set EnableEdit = false? I have version 1.6.1.8 installed. When I set EnableEdit to false, I can still delete characters from a cell by pressing the delete key. But I cannot insert characters into the cell contents. Is this the intended behaviour? In the meantime, I have set TableStyle.ReadOnly = true, and now my cell contents seem to be protected against all edits.

Administrator [Syncfusion]
Replied On February 19, 2004 06:15 AM

No, this is not intended behavior. Setting gridDataBoundGrid1.EnableEdit = false should essentially make the grid readonly. I tried to see the problem in 1.6.1.8 using this sample, but could not. Can you see the problem in this sample? If not, are you handling any events or setting properties that might affect this?

Richard Deverson
Replied On February 23, 2004 02:17 AM

Hello Clay, Thanks for your prompt reply. Yes I do see the problem in this sample. I use the cursor keys to navigate to another cell. Then I press the delete key. The cursor starts blinking at the beginning of the cell contents. I press the delete key again. The RowHeader displays the editing icon, and if I continue to press the delete key I can delete the cell contents. If I navigate with the mouse, and then press the delete key, there is no problem. I.e. I cannot delete the cell contents. >No, this is not intended behavior. Setting gridDataBoundGrid1.EnableEdit = false should essentially make the grid readonly. > >I tried to see the problem in 1.6.1.8 using this sample, but could not. Can you see the problem in this sample? If not, are you handling any events or setting properties that might affect this? >

Administrator [Syncfusion]
Replied On February 23, 2004 03:05 AM

Thanks for explaining how to see the problem. I was clicking around the grid, and not arrowing around it. Until we get this fixed, as you suggested, setting grid.TableStyle.ReadOnly = True when you set grid.EnableEdit = false should avoid this behavior.

CONFIRMATION

This post will be permanently deleted. Are you sure you want to continue?

Sorry, An error occured while processing your request. Please try again later.

You are using an outdated version of Internet Explorer that may not display all features of this and other websites. Upgrade to Internet Explorer 8 or newer for a better experience.

;