We use cookies to give you the best experience on our website. If you continue to browse, then you agree to our privacy policy and cookie policy. Image for the cookie policy date
close icon

Skipping Resource & Nuget Package versions are compatible and Can no resolve reference Errors

I'm using Syncfusion Essentials Studio 17.3.0.9. Until now, I've worked on WPF with Syncfusion and right from the start, I used easily Syncfusion WPF.
Nowadays I want to try using Syncfusion Xamarin Forms. But I encountered an error at this first step. Please help me. What's the issue?

In Visual Studio, my progress pathway: Syncfusion > Essential Studio for Xamarin > Create New Syncfusion Project > Syncfusion Xamarin Project Template

My project name is LastTried. Then opened New Project Configuration Wizard. I set Assemblies From > Installed Location. What I've done so far:

Image 1


And when the project is opened, I find such a warning list.

Image 2

I"ve created a new device via emulator and API. In normal Xamarin project, the emulator runs well. If I deploy the Syncfusion project into my android emulator device, here are warnings:

Image 3

6 Replies

BS Balasubramani Sundaram Syncfusion Team September 23, 2019 01:32 PM UTC

Hi Xamarin Hunter, 
   
Thank you for contacting Syncfusion support.    
   
Currently, we are validating the reported issue “NuGet package restoring and version compatibility issue”. We will validate and update you further details on September 25th, 2019. We appreciate your patience until then.     
 
Regards,
Balasubramani Sundaram. 



BS Balasubramani Sundaram Syncfusion Team September 25, 2019 03:58 PM UTC

Hi Xamarin Hunter,  
 
Thanks for your patience.  
 
Based on your provided details, we have created a sample and we analyzed the issue “NuGet package restoring and version compatibility issue” and we could able to replicate the issue in our end with SfDataGrid “Xamarin.Android.Support.InterPolator” when we have the target version 8.0  after setting the target version to 9.0 it has resolved. Please increase the target version and checked the reported issue.  
 
In PullToRefresh case we didn’t face any issue “Xamarin.Android.Support.SwipeRefreshlayout” when we had loaded the application on the simulator with API 9.0 as well in 8.0. Please share the solution explore image with the installed NuGet package details, it will help us to analysis more on this issue and provide the solution earlier. 
 
Regards, 
Balasubramani Sundaram. 



XH Xamarin Hunter replied to Balasubramani Sundaram November 18, 2019 10:19 PM UTC

Hi Xamarin Hunter,  
 
Thanks for your patience.  
 
Based on your provided details, we have created a sample and we analyzed the issue “NuGet package restoring and version compatibility issue” and we could able to replicate the issue in our end with SfDataGrid “Xamarin.Android.Support.InterPolator” when we have the target version 8.0  after setting the target version to 9.0 it has resolved. Please increase the target version and checked the reported issue.  
 
In PullToRefresh case we didn’t face any issue “Xamarin.Android.Support.SwipeRefreshlayout” when we had loaded the application on the simulator with API 9.0 as well in 8.0. Please share the solution explore image with the installed NuGet package details, it will help us to analysis more on this issue and provide the solution earlier. 
 
Regards, 
Balasubramani Sundaram. 


Thank you very much. With 9.0, It works great.


BS Balasubramani Sundaram Syncfusion Team November 19, 2019 05:18 AM UTC

Hi Xamarin Hunter,   
  
Thanks for the update.  
  
We are glad to know that the reported problem has been resolved at your end. Please let us know if you have any further queries on this. We are happy to help you.  
   
Regards,  
Balasubramani Sundaram. 



XH Xamarin Hunter replied to Balasubramani Sundaram November 29, 2019 11:02 PM UTC

Hi Xamarin Hunter,   
  
Thanks for the update.  
  
We are glad to know that the reported problem has been resolved at your end. Please let us know if you have any further queries on this. We are happy to help you.  
   
Regards,  
Balasubramani Sundaram. 


In Android Pie 9.0, on Xamarin.Android, everything is OK. But, in cross-platform, I faced this error despite of target framework Android 9.0. What's the reason?




BS Balasubramani Sundaram Syncfusion Team December 2, 2019 02:06 PM UTC

Hi Utemar,  
 
Thank you for the update.  
 
In cross – platforms it will cause when we upgraded the Xamarin. Forms version above 3.2. We suspect that you are using the Xamarin. Forms version above 3.2. Why because? On above 3.2 in Xamarin. Forms itself they have included the required android dependency package inside the platform renderer itself. In your android project under dependency, any package related to support library of android please uninstall it and set the Target platform 9.0 and clean the project and build it again. It will work fine. 
 
Please let us know after, did the solution steps you’re still facing an issue. Please provide your solution explorer image and android cs project file it will help us to analyze and provide the solution earlier.   
 
Please refer the below sample and provide image,  
 
 
 
 
 
 
 
 
 
 
 
 
 
We hope this helps. Please let us know, if you need any further assistance. 
 
Regards,
Balasubramani Sundaram.
 


Loader.
Live Chat Icon For mobile
Up arrow icon