We use cookies to give you the best experience on our website. If you continue to browse, then you agree to our privacy policy and cookie policy. (Last updated on : November 16, 2018).
Unfortunately, activation email could not send to your email. Please try again.
Syncfusion Feedback

Custom freeze border not setting for GroupCaptionSummaryCells

Thread ID:

Created:

Updated:

Platform:

Replies:

99091 Apr 27,2011 01:40 PM UTC May 9,2011 06:02 AM UTC ASP.NET Web Forms (Classic) 3
loading
Tags: GridGroupingControl
Andrew Whitlock
Asked On April 27, 2011 01:40 PM UTC

We use a custom border style to set the Right border of cells in the freeze column. Not all cells are using the style (see attached screen shot, some text has been edited from the cells).

We are using FreezeRange to set our freeze and then Appearence.AnyCell.Borders.Right to set the borders on the frozen column's column descriptor.

I can see that the cells not using our border style are using a different style than default to indicate a freeze (these have been circled in red in the screen shot). We would like these cells to use our style to show an unbroken, right border on the freeze column.



Capture_4bc94371.zip

Andrew Whitlock
Replied On April 27, 2011 02:35 PM UTC

I modified the MultiColumnGrouping_2010 sample to include some of our style of freeze logic.

Right click on a cell and select freeze and the employeeID column will freeze with a custom border. You can see that that group captions are not displaying the border even though they experience the freeze. Of course, in this example a border there wouldn't make sense, but for us we would like to see it.



freezegrouping_fdcd9790.zip

Andrew Whitlock
Replied On May 2, 2011 04:53 PM UTC

My mistake. This should be in the Windows Forms section and not ASP.NET.


Arulraj A [Syncfusion]
Replied On May 9, 2011 06:02 AM UTC

Hi Andrew,

Thanks for your interest in Syncfusion products

I am afraid that I cannot able to reproduce the reported issue in the provided sample. Could you please send us which version you are using and whether you have received any patch for that version? So that we could sort out the problem and provide solution respectively.

Have a look at the screenshot which is the output as expected
Error-2007210458.zip

Regards,
Arulraj.A



CONFIRMATION

This post will be permanently deleted. Are you sure you want to continue?

Sorry, An error occured while processing your request. Please try again later.

Warning Icon You are using an outdated version of Internet Explorer that may not display all features of this and other websites. Upgrade to Internet Explorer 8 or newer for a better experience.Close Icon

;